summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm27
1 files changed, 16 insertions, 11 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index e8003f88a3..c7bece868d 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -26,6 +26,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system cmake)
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (gnu packages autotools)
@@ -74,14 +75,15 @@ as ASCII text.")
(define-public freeglut
(package
(name "freeglut")
- (version "2.8.1")
+ (version "3.0.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/project/freeglut/freeglut/"
version "/freeglut-" version ".tar.gz"))
(sha256
- (base32 "16lrxxxd9ps9l69y3zsw6iy0drwjsp6m26d1937xj71alqk6dr6x"))))
- (build-system gnu-build-system)
+ (base32 "18knkyczzwbmyg8hr4zh8a1i5ga01np2jzd1rwmsh7mh2n2vwhra"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ; no test target
(inputs `(("mesa" ,mesa)
("libx11" ,libx11)
("libxi" ,libxi)
@@ -185,7 +187,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "10.5.4")
+ (version "11.0.3")
(source
(origin
(method url-fetch)
@@ -193,7 +195,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz"))
(sha256
(base32
- "00v89jna7m6r2w1yrnx09isc97r2bd1hkn4jib445n1078zp47mm"))))
+ "1mikw0biw0wxq0fn3cp18bm6kjrkd66fy84774yc5b91rvp94adb"))))
(build-system gnu-build-system)
(propagated-inputs
`(("glproto" ,glproto)
@@ -257,12 +259,10 @@ also known as DXTn or DXTC) for Mesa.")
"src/mesa/main/texcompress_s3tc.c")
(("\"libtxc_dxtn\\.so")
(string-append "\"" s2tc "/lib/libtxc_dxtn.so")))
- (substitute* "src/gallium/targets/egl-static/egl_st.c"
- (("\"libglapi\"")
- (string-append "\"" out "/lib/libglapi\"")))
(substitute* "src/loader/loader.c"
- (("dlopen\\(\"libudev\\.so")
- (string-append "dlopen(\"" udev "/lib/libudev.so")))
+ (("udev_handle = dlopen\\(name")
+ (string-append "udev_handle = dlopen(\""
+ udev "/lib/libudev.so\"")))
(substitute* "src/glx/dri_common.c"
(("dlopen\\(\"libGL\\.so")
(string-append "dlopen(\"" out "/lib/libGL.so")))
@@ -327,7 +327,12 @@ emulation to complete hardware acceleration for modern GPUs.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(arguments
- '(#:phases
+ '(;; XXX: fails to build against latest mesa:
+ ;; eglut.c: error: 'EGL_SCREEN_BIT_MESA' undeclared
+ ;;
+ ;; <https://bugs.freedesktop.org/show_bug.cgi?id=91643>
+ #:configure-flags '("--disable-egl")
+ #:phases
(modify-phases %standard-phases
(replace
'install