summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm68
1 files changed, 28 insertions, 40 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 3c68d86c96..1d43895f5c 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -57,7 +57,7 @@
(define dbus
(package
(name "dbus")
- (version "1.8.12")
+ (version "1.8.16")
(source (origin
(method url-fetch)
(uri
@@ -65,7 +65,7 @@
version ".tar.gz"))
(sha256
(base32
- "07jhcalg00i2rx5zrgk73rg0vm7lzi5q5z2gscrbl999ipr2h569"))
+ "01rba8mp8kqvmy6ibdmi806kjr3m14swnskqk02gyhykxxl54ybz"))
(patches (list (search-patch "dbus-localstatedir.patch")))))
(build-system gnu-build-system)
(arguments
@@ -119,7 +119,7 @@ shared NFS home directories.")
(define glib
(package
(name "glib")
- (version "2.42.1")
+ (version "2.44.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/"
@@ -127,7 +127,7 @@ shared NFS home directories.")
name "-" version ".tar.xz"))
(sha256
(base32
- "16pqvikrps1fvwwqvk0qi4a13mfg7gw6w5qfhk7bhi8f51jhhgwg"))
+ "1fgmjv3yzxgbks31h42201x2izpw0sd84h8dfw0si3x00sqn5lzj"))
(patches (list (search-patch "glib-tests-homedir.patch")
(search-patch "glib-tests-desktop.patch")
(search-patch "glib-tests-prlimit.patch")
@@ -176,7 +176,7 @@ shared NFS home directories.")
;; Note: `--docdir' and `--htmldir' are not honored, so work around it.
#:configure-flags (list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
- "/share/gtk-doc"))
+ "/share/gtk-doc/html"))
;; In 'gio/tests', 'gdbus-test-codegen-generated.h' is #included in a
;; file that gets compiled possibly before it has been fully generated.
@@ -189,7 +189,11 @@ shared NFS home directories.")
;; by 'glib-compile-schemas'.
(list (search-path-specification
(variable "XDG_DATA_DIRS")
- (files '("share")))))
+ (files '("share")))
+ ;; To load extra gio modules from glib-networking, etc.
+ (search-path-specification
+ (variable "GIO_EXTRA_MODULES")
+ (files '("lib/gio/modules")))))
(search-paths native-search-paths)
(synopsis "Thread-safe general utility library; basis of GTK+ and GNOME")
@@ -203,14 +207,14 @@ dynamic loading, and an object system.")
(define gobject-introspection
(package
(name "gobject-introspection")
- (version "1.42.0")
+ (version "1.44.0")
(source (origin
(method url-fetch)
- (uri (string-append "http://ftp.gnome.org/pub/GNOME/sources/"
+ (uri (string-append "mirror://gnome/sources/"
"gobject-introspection/" (version-major+minor version)
"/gobject-introspection-" version ".tar.xz"))
(sha256
- (base32 "1xwm7wmr9r9wp6xljb3bckx3a4siybavaq39w46ly7gpskxfv8iv"))
+ (base32 "1b972qg2yb51sdavfvb6kc19akwc15c1bwnbg81vadxamql2q33g"))
(patches (list
(search-patch "gobject-introspection-cc.patch")
(search-patch
@@ -239,14 +243,7 @@ dynamic loading, and an object system.")
(arguments
`(;; The patch 'gobject-introspection-absolute-shlib-path.patch' causes
;; some tests to fail.
- #:tests? #f
- #:phases
- (alist-cons-before
- 'configure 'patch-paths
- (lambda _
- (substitute* "giscanner/sourcescanner.py"
- (("GUIX_GCC_PATH") (which "gcc"))))
- %standard-phases)))
+ #:tests? #f))
(home-page "https://wiki.gnome.org/GObjectIntrospection")
(synopsis "Generate interface introspection data for GObject libraries")
(description
@@ -309,14 +306,14 @@ The intltool collection can be used to do these things:
(define itstool
(package
(name "itstool")
- (version "1.2.0")
+ (version "2.0.2")
(source (origin
(method url-fetch)
(uri (string-append "http://files.itstool.org/itstool/itstool-"
version ".tar.bz2"))
(sha256
(base32
- "1akq75aflihm3y7js8biy7b5mw2g11vl8yq90gydnwlwp0zxdzj6"))))
+ "0fh34wi52i0qikgvlmrcpf1vx6gc1xqdad4539l4d9hikfsrz45z"))))
(build-system gnu-build-system)
(propagated-inputs
`(("libxml2" ,libxml2)
@@ -346,7 +343,7 @@ translated.")
(define dbus-glib
(package
(name "dbus-glib")
- (version "0.102")
+ (version "0.104")
(source (origin
(method url-fetch)
(uri
@@ -354,7 +351,7 @@ translated.")
version ".tar.gz"))
(sha256
(base32
- "177j5p2vrvpmzk2xrrj6akn73kvpbvnmsjvlmca9l55qbdcfsr39"))))
+ "1xi1v1msz75qs0s4lkyf1psrksdppa3hwkg0mznc6gpw5flg3hdz"))))
(build-system gnu-build-system)
(inputs
`(("dbus" ,dbus)
@@ -373,14 +370,15 @@ by GDBus included in Glib.")
(define libsigc++
(package
(name "libsigc++")
- (version "2.3.1")
+ (version "2.4.1")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://gnome/sources/libsigc++/2.3/libsigc++-"
- version ".tar.xz"))
+ (uri (string-append "mirror://gnome/sources/libsigc++/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
(sha256
(base32
- "14q3sq6d43f6wfcmwhw4v1aal4ba0h5x9v6wkxy2dnqznd95il37"))))
+ "1v0rvkzglzmf67y9nkcppwjwi68j1cy5yhldvcq7xrv8594l612l"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("m4" ,m4)))
@@ -399,7 +397,7 @@ has an ease of use unmatched by other C++ callback libraries.")
(define glibmm
(package
(name "glibmm")
- (version "2.42.0")
+ (version "2.44.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/glibmm/"
@@ -407,7 +405,7 @@ has an ease of use unmatched by other C++ callback libraries.")
"/glibmm-" version ".tar.xz"))
(sha256
(base32
- "15rk3az8jh3rdwlc3lxjljbnh60drj3ka9574zd39lkqfgcq6l4q"))))
+ "1a1fczy7hcpn24fglyn4i79f4yjc8s50is70q03mb294bm1c02hv"))))
(build-system gnu-build-system)
(arguments
`(#:phases (alist-cons-before
@@ -481,8 +479,7 @@ useful for C++.")
(define-public python-pygobject
(package
(name "python-pygobject")
- (version "3.12.2") ;last version that works with
- ;gobject-introspection 1.38
+ (version "3.16.1")
(source
(origin
(method url-fetch)
@@ -491,8 +488,7 @@ useful for C++.")
"/pygobject-" version ".tar.xz"))
(sha256
(base32
- "08m5yad1hjdax4g39w6lgjk4124mcwpa8fc5iyvb8nygk8s3syky"))))
- ;; 3.14.0: 0m1d75iwxa6k1xbkn6c6yq5r10pxnf7i5c2a5yvwsnab7ylzz7kp
+ "1hqyma73w0lnjcgx68kawhnq84aq92xlkdqphrlc2ppia38dm5kx"))))
(build-system gnu-build-system)
(native-inputs
`(("which" ,which)
@@ -545,14 +541,6 @@ useful for C++.")
(base32
"1symyzbjmxvksn2ifdkk50lafjm2llf2sbmky062gq2pz3cg23cy"))))
(build-system gnu-build-system)
- (arguments
- '(#:phases (alist-cons-before
- 'build 'set-cc
- (lambda _
- ;; Set $CC so that g-ir-scanner works.
- (setenv "CC" "gcc")
- #t)
- %standard-phases)))
(native-inputs
`(("glib" ,glib "bin") ; uses glib-mkenums
("pkg-config" ,pkg-config)