summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cc8e2a0396..5a3ae2659d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9519,15 +9519,20 @@ shared object databases, search tools and indexing.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1cncyiyh79w1id6a6s2f0rxmgwl65lp4ml4afa0z35jrnwp2s8cr"))
- (patches
- (search-patches "nautilus-disable-tracker-tests.patch"))))
+ "1cncyiyh79w1id6a6s2f0rxmgwl65lp4ml4afa0z35jrnwp2s8cr"))))
(build-system meson-build-system)
(arguments
(list
#:glib-or-gtk? #t
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-tracker-tests
+ ;; The tracker test hangs in the build container (see:
+ ;; https://gitlab.gnome.org/GNOME/nautilus/-/issues/2486).
+ (lambda _
+ (substitute* "test/automated/displayless/meson.build"
+ (("^foreach t: tracker_tests" all)
+ (string-append "tracker_tests = []\n" all)))))
(add-after 'unpack 'make-extensible
(lambda _
(substitute* "src/nautilus-module.c"