summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm39
1 files changed, 23 insertions, 16 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 49ce573bd4..a339d577db 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5762,7 +5762,7 @@ faster results and to avoid unnecessary server load.")
(define-public upower
(package
(name "upower")
- (version "1.90.0")
+ (version "1.90.2")
(source
(origin
(method git-fetch)
@@ -5771,7 +5771,7 @@ faster results and to avoid unnecessary server load.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1g17rm91p8vfpjyb0k2shylrs55nccn3fa890vlk4n9s71sghbzq"))
+ (base32 "13xp423ycv8imf2cmgf6lii9f01p7x2v19cny7acrmczkc0cqv7d"))
(modules '((guix build utils)))
(snippet
;; Upstream commit <https://cgit.freedesktop.org/upower/commit/
@@ -5794,19 +5794,25 @@ faster results and to avoid unnecessary server load.")
;; If not specified, udev will try putting history information
;; in /gnu/store.
"-Dhistorydir=/var/lib/upower"
- (string-append "-Dudevrulesdir=" #$output "/bin/udev/rules.d"))
- #:phases (if (target-x86-32?)
- #~(modify-phases %standard-phases
- (add-after 'unpack 'adjust-test-for-excess-precision
- (lambda _
- ;; Address test failure caused by excess precision
- ;; on i686:
- ;; <https://gitlab.freedesktop.org/upower/upower/-/issues/214>.
- (substitute* "src/linux/integration-test.py"
- (("assertEqual(.*)40\\.0" _ middle)
- (string-append
- "assertAlmostEqual" middle "40.0"))))))
- #~%standard-phases)))
+ (string-append "-Dudevrulesdir=" #$output "/bin/udev/rules.d")
+ (string-append "-Dudevhwdbdir=" #$output "/lib/udev/hwdb.d"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'adjust-test-suite
+ (lambda _
+ ;; This test calls an unimplemented bluez dbus method.
+ (substitute* "src/linux/integration-test.py"
+ (("test_bluetooth_hidpp_mouse")
+ "disabled_test_bluetooth_hidpp_mouse"))
+ #$@(if (target-x86-32?)
+ ;; Address test failure caused by excess precision
+ ;; on i686:
+ ;; <https://gitlab.freedesktop.org/upower/upower/-/issues/214>.
+ '((substitute* "src/linux/integration-test.py"
+ (("assertEqual(.*)40\\.0" _ middle)
+ (string-append
+ "assertAlmostEqual" middle "40.0"))))
+ '()))))))
(native-inputs
(list `(,glib "bin") ; for gdbus-codegen
gobject-introspection
@@ -5820,11 +5826,12 @@ faster results and to avoid unnecessary server load.")
python-packaging
python-pygobject
umockdev
+ dbus
;; For man pages.
docbook-xsl
libxslt)) ; for 'xsltproc'
(inputs
- (list dbus-glib libgudev libusb))
+ (list libgudev libusb))
(propagated-inputs
;; In Requires of upower-glib.pc.
(list glib))