summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 96dcbda72e..fc19318b91 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -945,6 +945,7 @@ the GNOME desktop environment.")
(define-public libcroco
(package
(name "libcroco")
+ (replacement libcroco/fixed)
(version "0.6.11")
(source (origin
(method url-fetch)
@@ -972,6 +973,19 @@ XML/CSS rendering engine.")
;; LGPLv2.1-only.
(license license:lgpl2.1)))
+(define libcroco/fixed
+ (package
+ (inherit libcroco)
+ (replacement #f)
+ (source
+ (origin
+ (inherit (package-source libcroco))
+ (patches
+ (append
+ (origin-patches (package-source libcroco))
+ (search-patches "libcroco-CVE-2017-7960.patch"
+ "libcroco-CVE-2017-7961.patch")))))))
+
(define-public libgsf
(package
(name "libgsf")