summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm268
1 files changed, 86 insertions, 182 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 44effe2b2b..8199a8af29 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2387,7 +2387,7 @@ GNOME Desktop.")
(define-public gdl
(package
(name "gdl")
- (version "3.34.0")
+ (version "3.40.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2399,7 +2399,7 @@ GNOME Desktop.")
(file-name (git-file-name name version))
(sha256
(base32
- "154qcr0x6f68f4q526y87imv0rscmp34n47nk1pp82rsq52h2zna"))))
+ "11hp93gqk7m64h84q5hndzlwj4w6hl0cbmzrk2pkdn04ikm2zj4v"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf
@@ -3397,7 +3397,7 @@ for dealing with different structured file formats.")
(define-public librsvg
(package
(name "librsvg")
- (version "2.50.7")
+ (version "2.54.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/librsvg/"
@@ -3405,7 +3405,7 @@ for dealing with different structured file formats.")
"librsvg-" version ".tar.xz"))
(sha256
(base32
- "1g3f8byg5w08fx1bka12mmpl59v6a4q2p827w6m2la6mijq63yzz"))
+ "0cs8qbn2khibb5w1r0f6cibfmkfb7zg713526vhc0hva7wj2l5ga"))
(modules '((guix build utils)))
(snippet
'(begin (delete-file-recursively "vendor")))))
@@ -3418,61 +3418,57 @@ for dealing with different structured file formats.")
(guix build utils)
((guix build gnu-build-system) #:prefix gnu:))
#:cargo-inputs
- (("rust-bitflags" ,rust-bitflags-1)
- ("rust-cairo-rs" ,rust-cairo-rs-0.8)
- ("rust-cairo-sys-rs" ,rust-cairo-sys-rs-0.9)
- ("rust-cast" ,rust-cast-0.2)
- ("rust-cssparser" ,rust-cssparser-0.27)
+ (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-cairo-rs" ,rust-cairo-rs-0.15)
+ ("rust-cast" ,rust-cast-0.3)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-cssparser" ,rust-cssparser-0.28)
("rust-data-url" ,rust-data-url-0.1)
("rust-encoding" ,rust-encoding-0.2)
- ("rust-float-cmp" ,rust-float-cmp-0.8)
- ("rust-gdk-pixbuf" ,rust-gdk-pixbuf-0.8)
- ("rust-gdk-pixbuf-sys" ,rust-gdk-pixbuf-sys-0.9)
- ("rust-gio" ,rust-gio-0.8)
- ("rust-gio-sys" ,rust-gio-sys-0.9)
- ("rust-glib" ,rust-glib-0.9)
- ("rust-glib-sys" ,rust-glib-sys-0.9)
- ("rust-gobject-sys" ,rust-gobject-sys-0.9)
- ("rust-itertools" ,rust-itertools-0.9)
- ("rust-language-tags" ,rust-language-tags-0.2)
+ ("rust-float-cmp" ,rust-float-cmp-0.9)
+ ("rust-gdk-pixbuf" ,rust-gdk-pixbuf-0.15)
+ ("rust-gio" ,rust-gio-0.15)
+ ("rust-glib" ,rust-glib-0.15)
+ ("rust-itertools" ,rust-itertools-0.10)
+ ("rust-language-tags" ,rust-language-tags-0.3)
("rust-libc" ,rust-libc-0.2)
("rust-locale-config" ,rust-locale-config-0.3)
("rust-markup5ever" ,rust-markup5ever-0.10)
- ("rust-nalgebra" ,rust-nalgebra-0.21)
+ ("rust-nalgebra" ,rust-nalgebra-0.29)
("rust-num-traits" ,rust-num-traits-0.2)
("rust-once-cell" ,rust-once-cell-1)
- ("rust-pkg-config" ,rust-pkg-config-0.3)
- ("rust-pango" ,rust-pango-0.8)
- ("rust-pango-sys" ,rust-pango-sys-0.9)
- ("rust-pangocairo" ,rust-pangocairo-0.9)
+ ("rust-pango" ,rust-pango-0.15)
+ ("rust-pangocairo" ,rust-pangocairo-0.15)
("rust-rayon" ,rust-rayon-1)
- ("rust-rctree" ,rust-rctree-0.3)
+ ("rust-rctree" ,rust-rctree-0.4)
("rust-rgb" ,rust-rgb-0.8)
("rust-regex" ,rust-regex-1)
- ("rust-selectors" ,rust-selectors-0.22)
+ ("rust-selectors" ,rust-selectors-0.23)
("rust-string-cache" ,rust-string-cache-0.8)
- ("rust-tinyvec" ,rust-tinyvec-0.3)
+ ("rust-tinyvec" ,rust-tinyvec-1)
("rust-url" ,rust-url-2)
("rust-xml5ever" ,rust-xml5ever-0.16))
#:cargo-development-inputs
- (("rust-assert-cmd" ,rust-assert-cmd-1)
- ("rust-cairo-rs" ,rust-cairo-rs-0.8)
+ (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-assert-cmd" ,rust-assert-cmd-2)
+ ("rust-cairo-rs" ,rust-cairo-rs-0.15)
("rust-chrono" ,rust-chrono-0.4)
("rust-criterion" ,rust-criterion-0.3)
- ("rust-float-cmp" ,rust-float-cmp-0.8)
+ ("rust-glib" ,rust-glib-0.15)
+ ("rust-libc" ,rust-libc-0.2)
("rust-lopdf" ,rust-lopdf-0.26)
- ("rust-png" ,rust-png-0.16)
- ("rust-predicates" ,rust-predicates-1)
- ("rust-tempfile" ,rust-tempfile-3))
+ ("rust-matches" ,rust-matches-0.1)
+ ("rust-png" ,rust-png-0.17)
+ ("rust-predicates" ,rust-predicates-2)
+ ("rust-proptest" ,rust-proptest-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-tempfile" ,rust-tempfile-3)
+ ("rust-test-generator" ,rust-test-generator-0.3)
+ ("rust-yeslogic-fontconfig-sys" ,rust-yeslogic-fontconfig-sys-2))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-docbook-xml
- (lambda* (#:key inputs #:allow-other-keys)
- (with-directory-excursion "doc"
- (substitute* "rsvg-docs.xml"
- (("http://www.oasis-open.org/docbook/xml/4.3/")
- (string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/"))))))
(add-after 'unpack 'prepare-for-build
(lambda _
;; In lieu of #:make-flags
@@ -3513,30 +3509,6 @@ for dealing with different structured file formats.")
(string-append vendor-dir "/" ,name "-" ,version ".tar.xz"))))
(replace 'build
(assoc-ref gnu:%standard-phases 'build))
- (add-before 'check 'ignore-failing-tests
- ;; stderr=```/tmp/guix-build-.../librsvg-2.50.1/rsvg-convert: line 150: ls: command not found
- (lambda _
- (substitute* "tests/src/cmdline/rsvg_convert.rs"
- (("fn background_color_option_invalid_color_yields_error" all)
- (string-append "#[ignore] " all))
- (("fn empty_input_yields_error" all)
- (string-append "#[ignore] " all))
- (("fn empty_svg_yields_error" all)
- (string-append "#[ignore] " all))
- (("fn env_source_data_epoch_empty" all)
- (string-append "#[ignore] " all))
- (("fn env_source_data_epoch_no_digits" all)
- (string-append "#[ignore] " all))
- (("fn env_source_data_epoch_trailing_garbage" all)
- (string-append "#[ignore] " all))
- (("fn export_id_option_error" all)
- (string-append "#[ignore] " all))
- (("fn huge_zoom_factor_yields_error" all)
- (string-append "#[ignore] " all))
- (("fn multiple_input_files_not_allowed_for_png_output" all)
- (string-append "#[ignore] " all))
- (("fn stylesheet_option_error" all)
- (string-append "#[ignore] " all)))))
(replace 'check
(lambda* args
((assoc-ref gnu:%standard-phases 'check)
@@ -3544,8 +3516,7 @@ for dealing with different structured file formats.")
(replace 'install
(assoc-ref gnu:%standard-phases 'install)))))
(native-inputs
- (list docbook-xml-4.3
- `(,glib "bin")
+ (list `(,glib "bin")
gobject-introspection
pkg-config
vala))
@@ -3561,34 +3532,6 @@ diagrams.")
(home-page "https://wiki.gnome.org/LibRsvg")
(license license:lgpl2.1+)))
-;; This copy of librsvg uses the bundled rust libraries. It is useful for
-;; packages which have too many dependencies to be rebuilt as frequently
-;; as the rust inputs are updated.
-;; TODO: Remove this package and use packaged rust libraries!
-(define-public librsvg-bootstrap
- (package
- (inherit librsvg)
- (name "librsvg")
- (version "2.50.7")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/librsvg/"
- (version-major+minor version) "/"
- "librsvg-" version ".tar.xz"))
- (sha256
- (base32
- "1g3f8byg5w08fx1bka12mmpl59v6a4q2p827w6m2la6mijq63yzz"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (for-each delete-file (find-files "vendor" "\\.a$"))))))
- (arguments
- (substitute-keyword-arguments (package-arguments librsvg)
- ((#:vendor-dir _ "vendor") "vendor")
- ((#:cargo-inputs _) '())
- ((#:cargo-development-inputs _) '())))
- (properties '((hidden? . #t)))))
-
(define-public librsvg-2.40
;; This is the last version implemented in C.
(package
@@ -4378,60 +4321,6 @@ passwords in the GNOME keyring.")
(define-public vala
(package
(name "vala")
- (version "0.54.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/vala/"
- (version-major+minor version) "/"
- "vala-" version ".tar.xz"))
- (sha256
- (base32
- "048k5c6c6y7jyb961krnrb7m0kghr0yrkpnfx3j5ckbx652yfkc8"))))
- (build-system glib-or-gtk-build-system)
- (arguments
- '(#:configure-flags '("--enable-coverage")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-docbook-xml
- (lambda* (#:key inputs #:allow-other-keys)
- (with-directory-excursion "doc/manual"
- (substitute* '("manual.xml" "version.xml.in")
- (("http://www.oasis-open.org/docbook/xml/4.4/")
- (string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/"))))))
- (add-before 'check 'pre-check
- (lambda _
- (setenv "CC" "gcc")
- (substitute* "valadoc/tests/libvaladoc\
-/tests-extra-environment.sh"
- (("export PKG_CONFIG_PATH=" m)
- (string-append m "$PKG_CONFIG_PATH:"))))))))
- (native-inputs
- `(("bison" ,bison)
- ("dbus" ,dbus) ; for dbus tests
- ("docbook-xml" ,docbook-xml-4.4)
- ("docbook-xsl" ,docbook-xsl)
- ("flex" ,flex)
- ("gobject-introspection" ,gobject-introspection) ; for gir tests
- ("help2man" ,help2man)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("xsltproc" ,libxslt)))
- (propagated-inputs
- `(("glib" ,glib) ; required by libvala-0.40.pc
- ("libgvc" ,graphviz)))
- (home-page "https://wiki.gnome.org/Projects/Vala/")
- (synopsis "Compiler using the GObject type system")
- (description "Vala is a programming language using modern high level
-abstractions without imposing additional runtime requirements and without using
-a different ABI compared to applications and libraries written in C. Vala uses
-the GObject type system and has additional code generation routines that make
-targeting the GNOME stack simple.")
- (license license:lgpl2.1+)))
-
-(define-public vala-next
- (package
- (inherit vala)
(version "0.56.2")
(source (origin
(method url-fetch)
@@ -4441,6 +4330,7 @@ targeting the GNOME stack simple.")
(sha256
(base32
"0k0jj3xwjq222x0hbqqy5bykhgk1f1wsb85bqcdgsnbqn6dn3jb6"))))
+ (build-system glib-or-gtk-build-system)
(arguments
(list
#:configure-flags #~(list "CC=gcc" "--enable-coverage")
@@ -4465,7 +4355,29 @@ targeting the GNOME stack simple.")
;; Wrapping the binaries breaks vala's behavior adaptations based on
;; the file name of the program executed (vala: compile and execute,
;; valac: compile into a binary).
- (delete 'glib-or-gtk-wrap))))))
+ (delete 'glib-or-gtk-wrap))))
+ (native-inputs
+ (list bison
+ dbus ; for dbus tests
+ docbook-xml-4.4
+ docbook-xsl
+ flex
+ gobject-introspection ; for gir tests
+ help2man
+ perl
+ pkg-config
+ libxslt))
+ (propagated-inputs
+ (list glib ; required by libvala-0.40.pc
+ graphviz))
+ (home-page "https://wiki.gnome.org/Projects/Vala/")
+ (synopsis "Compiler using the GObject type system")
+ (description "Vala is a programming language using modern high level
+abstractions without imposing additional runtime requirements and without using
+a different ABI compared to applications and libraries written in C. Vala uses
+the GObject type system and has additional code generation routines that make
+targeting the GNOME stack simple.")
+ (license license:lgpl2.1+)))
;;; An older variant kept to build libsoup-minimal-2.
(define-public vala-0.52
@@ -4640,16 +4552,16 @@ and RDP protocols.")
(inputs
(list gtk+ dbus))
(native-inputs
- `(("bash-completion" ,bash-completion)
- ("libxslt" ,libxslt) ;for xsltproc
- ("libxml2" ,libxml2) ;for XML_CATALOG_FILES
- ("docbook-xml" ,docbook-xml-4.2)
- ("docbook-xsl" ,docbook-xsl)
- ("glib:bin" ,glib "bin")
- ("gtk-doc" ,gtk-doc/stable)
- ("pkg-config" ,pkg-config)
- ("python" ,python)
- ("vala" ,vala)))
+ (list bash-completion
+ libxslt ;for xsltproc
+ libxml2 ;for XML_CATALOG_FILES
+ docbook-xml-4.2
+ docbook-xsl
+ `(,glib "bin")
+ gtk-doc/stable
+ pkg-config
+ python
+ vala))
(arguments
`(#:glib-or-gtk? #t
#:configure-flags '("-Dgtk_doc=true")
@@ -4825,8 +4737,7 @@ indicators etc).")
(search-patch
"glib-networking-32-bit-time.patch")))))))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("gettext" ,gettext-minimal)))
+ (list pkg-config gettext-minimal))
(inputs
(list glib gnutls gsettings-desktop-schemas libproxy))
(home-page "https://wiki.gnome.org/Projects/GLib")
@@ -4858,14 +4769,10 @@ from the GSettings schemas in gsettings-desktop-schemas.")
#:configure-flags
'("--with-ca-certificates=/etc/ssl/certs/ca-certificates.crt")))
(native-inputs
- `(("glib-mkenums" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)))
+ (list `(,glib "bin") gobject-introspection pkg-config))
(propagated-inputs
;; rest-0.7.pc refers to all these.
- `(("glib" ,glib)
- ("libsoup" ,libsoup-minimal-2)
- ("libxml2" ,libxml2)))
+ (list glib libsoup-minimal-2 libxml2))
(home-page "https://www.gtk.org/")
(synopsis "RESTful web api query library")
(description
@@ -4878,7 +4785,7 @@ libxml to ease remote use of the RESTful API.")
(define-public libsoup-minimal
(package
(name "libsoup-minimal")
- (version "3.0.4")
+ (version "3.0.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/libsoup/"
@@ -4886,7 +4793,7 @@ libxml to ease remote use of the RESTful API.")
"libsoup-" version ".tar.xz"))
(sha256
(base32
- "0ysnvvfd2f6w2z6g31spqqb8wgyamixc7mryzbbpyw0z15g8plsv"))))
+ "1j7p3cz6hwi9js9rp0pbas7cdln97yg9v2l1nv5imhcr6p7r1pzb"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dgtk_doc=false")
@@ -4911,7 +4818,6 @@ libxml to ease remote use of the RESTful API.")
(native-inputs
(list `(,glib "bin") ;for glib-mkenums
gobject-introspection
- intltool
pkg-config
python-wrapper
vala
@@ -4940,8 +4846,9 @@ and the GLib main loop, to integrate well with GNOME applications.")
;;; An older variant kept to build the 'rest' package.
(define-public libsoup-minimal-2
- (package/inherit libsoup-minimal
- (version "2.72.0")
+ (package
+ (inherit libsoup-minimal)
+ (version "2.74.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/libsoup/"
@@ -4949,7 +4856,7 @@ and the GLib main loop, to integrate well with GNOME applications.")
"libsoup-" version ".tar.xz"))
(sha256
(base32
- "11skbyw2pw32178q3h8pi7xqa41b2x4k6q4k9f75zxmh8s23y30p"))))
+ "0n8is108n0dn4dw7nm2wq9rydcm1vy47w40wywfrxqazdrjjg97h"))))
(arguments
(substitute-keyword-arguments (package-arguments libsoup-minimal)
((#:phases phases)
@@ -6938,16 +6845,13 @@ of running programs and invoke methods on those interfaces.")
(base32 "19d46rkajvr0f04560vlrzwvac88x5j8ilvzwkawbn5vjg069kf8"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags
- (list
- "--enable-doc")))
+ '(#:configure-flags '("--enable-doc")))
(native-inputs
- `(("ducktype" ,mallard-ducktype)
- ("gettext" ,gettext-minimal)
- ("intltool" ,intltool)
- ("itstool" ,itstool)
- ("xmllint" ,libxml2)
- ("xsltproc" ,libxslt)))
+ (list mallard-ducktype
+ gettext-minimal
+ itstool
+ libxml2
+ libxslt))
(synopsis "XSL stylesheets for Yelp")
(description "Yelp-XSL is a collection of programs and data files to help
you build, maintain, and distribute documentation. It provides XSLT stylesheets