summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm66
1 files changed, 52 insertions, 14 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 16ee2f290d..ebc9717cd1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -51,7 +51,7 @@
;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
-;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021, 2022, 2023 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020, 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020, 2022 Michael Rohleder <mike@rohleder.de>
@@ -1900,7 +1900,7 @@ either on a local, or remote machine via a number of methods.")
(define-public gnome-commander
(package
(name "gnome-commander")
- (version "1.14.3")
+ (version "1.16.1")
(source
(origin
(method url-fetch)
@@ -1908,8 +1908,10 @@ either on a local, or remote machine via a number of methods.")
(version-major+minor version) "/"
"gnome-commander-" version ".tar.xz"))
(sha256
- (base32 "0yzx9slg632iflw9p96nlh9i50dhacq7hrzpkj8b48mr1zkxrn3q"))))
- (build-system glib-or-gtk-build-system)
+ (base32 "1cyh20nz2f81rb6di99idvw4xjn969mjhj3n2q17kzjhlv20079z"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t))
(native-inputs
(list desktop-file-utils
flex
@@ -1917,6 +1919,7 @@ either on a local, or remote machine via a number of methods.")
`(,glib "bin")
gobject-introspection
googletest
+ `(,gtk+-2 "bin")
intltool
itstool
libtool
@@ -3576,11 +3579,19 @@ for dealing with different structured file formats.")
;; https://gitlab.gnome.org/GNOME/librsvg/-/issues/955).
(substitute* "gdk-pixbuf-loader/librsvg.thumbnailer.in"
(("@bindir@/gdk-pixbuf-thumbnailer")
- (search-input-file inputs "bin/gdk-pixbuf-thumbnailer")))))
+ (string-append #$(this-package-input "gdk-pixbuf")
+ "/bin/gdk-pixbuf-thumbnailer")))))
(add-after 'unpack 'prepare-for-build
(lambda _
;; In lieu of #:make-flags
(setenv "CC" #$(cc-for-target))
+ (setenv "PKG_CONFIG" #$(pkg-config-for-target))
+ (when #$(%current-target-system)
+ (setenv "RUST_TARGET"
+ (string-replace
+ #$(%current-target-system)
+ "-unknown-linux-gnu"
+ (string-index #$(%current-target-system) #\-))))
;; Something about the build environment resists building
;; successfully with the '--locked' flag.
(substitute* '("Makefile.am" "Makefile.in")
@@ -3613,9 +3624,18 @@ for dealing with different structured file formats.")
(apply (assoc-ref gnu:%standard-phases 'configure)
#:configure-flags
(list "--disable-static"
- "--enable-vala"
- (string-append "--with-html-dir=" #$output
- "/share/gtk-doc/html"))
+ #$@(if (%current-target-system)
+ #~(;; g-ir-scanner can't import its modules
+ ;; and vala currently can't be cross-compiled.
+ "--enable-introspection=no"
+ "--enable-vala=no"
+ ;; These two are necessary for cross-compiling.
+ (string-append
+ "--build=" #$(nix-system->gnu-triplet
+ (%current-system)))
+ (string-append
+ "--host=" #$(%current-target-system)))
+ #~("--enable-vala")))
args)))
(add-after 'configure 'dont-vendor-self
(lambda* (#:key vendor-dir #:allow-other-keys)
@@ -3625,13 +3645,14 @@ for dealing with different structured file formats.")
(replace 'build
(assoc-ref gnu:%standard-phases 'build))
(replace 'check
- (lambda* args
- ((assoc-ref gnu:%standard-phases 'check)
- #:test-target "check")))
+ (lambda* (#:key tests? #:allow-other-keys #:rest args)
+ (when tests?
+ ((assoc-ref gnu:%standard-phases 'check)
+ #:test-target "check"))))
(replace 'install
(assoc-ref gnu:%standard-phases 'install)))))
- (native-inputs (list `(,glib "bin") gobject-introspection pkg-config vala))
- (inputs (list freetype harfbuzz libxml2 pango))
+ (native-inputs (list gdk-pixbuf `(,glib "bin") gobject-introspection pkg-config vala))
+ (inputs (list freetype gobject-introspection harfbuzz libxml2 pango))
(propagated-inputs (list cairo gdk-pixbuf glib))
(synopsis "SVG rendering library")
(description "Librsvg is a library to render SVG images to Cairo surfaces.
@@ -8735,8 +8756,25 @@ the available networks and allows users to easily switch between them.")
library.")
(license license:lgpl2.1+)))
-;; This is the last release providing the 2.6 API, hence the name.
;; This is needed by tascam-gtk
+(define-public libxml++-3
+ (package
+ (inherit libxml++)
+ (name "libxml++")
+ (version "3.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libxmlplusplus/libxmlplusplus")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07f6l9ka63dnc85npxq5g7bn1ja7lad0w2wixqdlyabdvc4l2hp5"))))
+ (propagated-inputs (modify-inputs (package-propagated-inputs libxml++)
+ (append glibmm-2.64)))))
+
+;; This is the last release providing the 2.6 API, hence the name.
(define-public libxml++-2
(package
(inherit libxml++)