summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index af809d69c5..c17ce2719e 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -13,12 +13,13 @@
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2019, 2020 Adrian Malacoda <malacoda@monarch-pass.net>
-;;; Copyright © 2020, 2021, 2022 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2020-2023 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Baptiste Strazzul <bstrazzull@hotmail.fr>
+;;; Copyright © 2022 SeerLite <seerlite@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1053,6 +1054,7 @@ variable defined below. It requires guile-json to be installed."
"eudev"
"pulseaudio"
;; For the integration of native notifications
+ ;; (same reason as icedove)
"libnotify"))))
(wrap-program (car (find-files lib "^icecat$"))
`("XDG_DATA_DIRS" prefix (,gtk-share))
@@ -1286,8 +1288,8 @@ standards of the IceCat project.")
"--sort=name"
icecat-dir)))))))))
-(define %icedove-build-id "20230328000000") ;must be of the form YYYYMMDDhhmmss
-(define %icedove-version "102.9.1")
+(define %icedove-build-id "20230411000000") ;must be of the form YYYYMMDDhhmmss
+(define %icedove-version "102.10.0")
;; Provides the "comm" folder which is inserted into the icecat source.
;; Avoids the duplication of Icecat's source tarball.
@@ -1296,11 +1298,11 @@ standards of the IceCat project.")
(method hg-fetch)
(uri (hg-reference
(url "https://hg.mozilla.org/releases/comm-esr102")
- (changeset "a8965ef0b30705f497df3df718db60d9dc2c304f")))
+ (changeset "d8df3bebc4b529388b62b9cb4df152f13910fbe3")))
(file-name (string-append "thunderbird-" %icedove-version "-checkout"))
(sha256
(base32
- "14lj30a9hmiwxpriyfls245y1wj2j3hfwrsbf7s5d9ligjqldjag"))))
+ "1m46nxnq4jpp4p6qqw68pphhccxlz4zzbyyb8iq26zvp42x7ic8f"))))
(define (comm-source->locales+changeset source)
"Given SOURCE, a checkout of the Thunderbird 'comm' component, return the
@@ -1651,10 +1653,13 @@ ca495991b7852b855"))
(pulseaudio #$(this-package-input "pulseaudio"))
(pulseaudio-lib (string-append pulseaudio "/lib"))
(eudev #$(this-package-input "eudev"))
- (eudev-lib (string-append eudev "/lib")))
+ (eudev-lib (string-append eudev "/lib"))
+ ;; For the integration of native notifications (same reason as icecat)
+ (libnotify #$(this-package-input "libnotify"))
+ (libnotify-lib (string-append libnotify "/lib")))
(wrap-program (car (find-files lib "^icedove$"))
`("XDG_DATA_DIRS" prefix (,gtk-share))
- `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib ,eudev-lib)))))))))
+ `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib ,eudev-lib ,libnotify-lib)))))))))
(inputs
(list alsa-lib
bzip2
@@ -1675,6 +1680,7 @@ ca495991b7852b855"))
libffi
libgnome
libjpeg-turbo
+ libnotify
libpng-apng
libvpx
libxcomposite