summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm31
1 files changed, 20 insertions, 11 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 1ffec770fa..e6d29d5f90 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Ivan Petkov <ivanppetkov@gmail.com>
-;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2020, 2024 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2019, 2020 Adrian Malacoda <malacoda@monarch-pass.net>
;;; Copyright © 2020-2023 Jonathan Brielmaier <jonathan.brielmaier@web.de>
@@ -176,6 +176,14 @@
((".*killed process should not have exitStatus.*")
""))
+ ;; This was fixed sometime between 102.15.1 and 115.11.0.
+ ;; These tests are supposed to be skipped on all 64-bit systems.
+ #$@(if (target-riscv64?)
+ #~((substitute* '("non262/Array/regress-157652.js"
+ "non262/regress/regress-422348.js")
+ (("mips64") "mips64|riscv64")))
+ #~())
+
;; The test suite expects a lightly patched ICU. Disable tests
;; that do not work with the system version. See
;; "intl/icu-patches" for clues.
@@ -414,7 +422,7 @@ variable defined below. It requires guile-json to be installed."
(format #t "~{~s~%~}" data)
data))))
-(define all-mozilla-locales
+(define-public all-mozilla-locales
(mozilla-locales
;; sha256 changeset locale
;;---------------------------------------------------------------------------
@@ -495,6 +503,7 @@ variable defined below. It requires guile-json to be installed."
("0c8dl12n5fjdd3bjaf8idyaxsf8ppbma132vdw8bk2wqnh4cv69a" "92110fd6e211" "rm")
("0mxxy56kj0k5jhjxjv8v4zz57pha819mz7j803lcilax7w52wgca" "5eeba1f64743" "ro")
("0jrd95n108r4sxdwgy39zjynm5nlzzmiijsfpxxfwj7886wl4faz" "47131134e349" "ru")
+ ("1lwm5jv3hvjp84a70186x2083nhr3mfcl7kpmw5in9amaflfi41b" "a5cd6d3d67ee" "sat")
("1q6pn3iixzcas9blf61bhvwgppbsh0am0wdz6a6p9f9978894d73" "880b7986692a" "sc")
("0xndsph4v725q3xcpmxxjb9vxv19sssqnng82m9215cdsv9klgpb" "bf5f6e362f6f" "sco")
("0l70n8817mbmbc09fsnn2aqjj9k9dhad2gmzgphmiilf9mqm2dpf" "1f705c926a99" "si")
@@ -523,9 +532,9 @@ variable defined below. It requires guile-json to be installed."
;; XXXX: Workaround 'snippet' limitations.
(define computed-origin-method (@@ (guix packages) computed-origin-method))
-(define %icecat-base-version "115.10.0")
+(define %icecat-base-version "115.12.0")
(define %icecat-version (string-append %icecat-base-version "-guix0-preview1"))
-(define %icecat-build-id "20240416000000") ;must be of the form YYYYMMDDhhmmss
+(define %icecat-build-id "20240611000000") ;must be of the form YYYYMMDDhhmmss
;; 'icecat-source' is a "computed" origin that generates an IceCat tarball
;; from the corresponding upstream Firefox ESR tarball, using the 'makeicecat'
@@ -545,12 +554,12 @@ variable defined below. It requires guile-json to be installed."
"firefox-" upstream-firefox-version ".source.tar.xz"))
(sha256
(base32
- "1wpf4vcrvnvhnfzqavbkzqbn51bds1l9f6ld4mzh9xwm7mrkrz8a"))))
+ "1vx88wc10fjkvqdqf3ab65qk3km7z0mlyf9plxjhabxvl0jid7mm"))))
;; The upstream-icecat-base-version may be older than the
;; %icecat-base-version.
- (upstream-icecat-base-version "115.10.0")
- (gnuzilla-commit "40e114e5e8fd0b4d3621d6c8aebf0c78100578f2")
+ (upstream-icecat-base-version "115.12.0")
+ (gnuzilla-commit "f200ffe88821f66234591096bcbe87b0c11f8da0")
(gnuzilla-source
(origin
(method git-fetch)
@@ -562,7 +571,7 @@ variable defined below. It requires guile-json to be installed."
(string-take gnuzilla-commit 8)))
(sha256
(base32
- "1x6miiafhv9ncddm7xxjz88amq9bpv6sqnw5k0yz6fy1ghw9ckw0"))))
+ "154rjpn4vr2hqyrfbpwp6dvkzsv1cwisdf82v7dsda55012qaxg7"))))
;; 'search-patch' returns either a valid file name or #f, so wrap it
;; in 'assume-valid-file-name' to avoid 'local-file' warnings.
@@ -2084,7 +2093,7 @@ associated with their name."))
(define-public firefox-decrypt
(package
(name "firefox-decrypt")
- (version "0.7.0")
+ (version "1.1.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2093,7 +2102,7 @@ associated with their name."))
(file-name (git-file-name name version))
(sha256
(base32
- "17yyyxp47z4m8hnflcq34rc1y871515kr3f1y42j1l0yx3g0il07"))))
+ "0dnyl5z7kcgmgdgbz7vg8ha21pk9jiympvq0qc97lgdcdd8wxy0w"))))
(build-system trivial-build-system)
(inputs
(list nss python))
@@ -2109,7 +2118,7 @@ associated with their name."))
"/firefox_decrypt.py")
"firefox_decrypt.py")
(substitute* "firefox_decrypt.py"
- (("/usr/bin/env python") (which "python3"))
+ (("/usr/bin/env python3") (which "python3"))
(("libnss3.so") (string-append (assoc-ref %build-inputs "nss")
"/lib/nss/libnss3.so")))
(install-file "firefox_decrypt.py" (string-append %output "/bin"))