summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 262048a235..fb5d002b9b 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -111,6 +111,20 @@ simplifications, and enforces style rules.")
Using static analysis, it finds bugs and performance issues, offers
simplifications, and enforces style rules.")))
+(define-public go-structlayout
+ (package
+ (inherit go-honnef-co-go-tools)
+ (name "go-structlayout")
+ (arguments
+ `(#:import-path "honnef.co/go/tools/cmd/structlayout"
+ #:unpack-path "honnef.co/go/tools"
+ #:install-source? #f))
+ (synopsis "Display the layout (field sizes and padding) of structs in Go")
+ (description "This package prints the layout of a struct in Go, which is
+the byte offset and size of each field, respecting padding. This information
+is printed in human-readable form by default, or as JSON with the @code{-json}
+flag.")))
+
(define-public go-github-com-alecthomas-assert
(let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
(revision "1"))