summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm88
1 files changed, 88 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index ec886985d6..c7b6e94791 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1,8 +1,10 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
@@ -378,6 +380,92 @@ builds on top of Go's builtin @code{testing} library and is complemented by the
Gomega matcher library.")
(license license:expat)))
+(define-public go-github.com-smartystreets-assertions
+ (package
+ (name "go-github.com-smartystreets-assertions")
+ (version "1.13.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/smartystreets/assertions")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "0flf3fb6fsw3bk1viva0fzrzw87djaj1mqvrx2gzg1ssn7xzfrzr"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/smartystreets/assertions"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (unless
+ ;; The tests fail when run with gccgo.
+ (false-if-exception (search-input-file inputs "/bin/gccgo"))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
+ (native-inputs
+ (list go-github.com-smartystreets-gunit))
+ (home-page "https://github.com/smartystreets/assertions")
+ (synopsis "Assertions for testing with Go")
+ (description "The @code{assertions} package provides convenient assertion
+functions for writing tests in Go.")
+ (license license:expat)))
+
+(define-public go-github.com-smartystreets-goconvey
+ (package
+ (name "go-github.com-smartystreets-goconvey")
+ (version "1.6.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/smartystreets/goconvey")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ph18rkl3ns3fgin5i4j54w5a69grrmf3apcsmnpdn1wlrbs3dxh"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/smartystreets/goconvey"))
+ (propagated-inputs
+ (list go-github.com-jtolds-gls go-github.com-smartystreets-assertions))
+ (home-page "https://github.com/smartystreets/goconvey")
+ (synopsis "Go testing tool with both a web and terminal user interface")
+ (description "GoConvey is a testing tool for Go. It integrates with go
+test, can show test coverage and has a web user interface that will refresh
+automatically.")
+ (license license:expat)))
+
+(define-public go-github.com-smartystreets-gunit
+ (package
+ (name "go-github.com-smartystreets-gunit")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/smartystreets/gunit")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00m4zg0kdj49mnpmf9klb44ba71p966xsk6zknrzqgfc8119f35z"))))
+ (build-system go-build-system)
+ (arguments
+ '(;; TODO: This package depends on go-github.com-smartystreets-assertions
+ ;; for running the tests, but go-github.com-smartystreets-assertions
+ ;; depends on this package, so break this loop by not running the tests
+ ;; for this package.
+ #:tests? #f
+ #:import-path "github.com/smartystreets/gunit"))
+ (home-page "https://github.com/smartystreets/gunit")
+ (synopsis "Testing tool for Go, in the style of xUnit")
+ (description "@code{gunit} allows the test author to use a struct as the
+scope for a group of related test cases, in the style of xUnit fixtures. This
+makes extraction of setup/teardown behavior (as well as invoking the system
+under test) much simpler.")
+ (license license:expat)))
+
(define-public go-github-com-stretchr-testify
(package
(name "go-github-com-stretchr-testify")