summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-compression.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-compression.scm')
-rw-r--r--gnu/packages/golang-compression.scm45
1 files changed, 38 insertions, 7 deletions
diff --git a/gnu/packages/golang-compression.scm b/gnu/packages/golang-compression.scm
index b999c063ee..a1ad00f588 100644
--- a/gnu/packages/golang-compression.scm
+++ b/gnu/packages/golang-compression.scm
@@ -140,6 +140,33 @@ library included in the stdlib, and supports GIF, TIFF and PDF.")
(description "@code{compress} provides various compression algorithms.")
(license license:bsd-3)))
+(define-public go-github-com-klauspost-pgzip
+ (package
+ (name "go-github-com-klauspost-pgzip")
+ (version "1.2.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/klauspost/pgzip")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j29wr6nd9ncdbkjphyziv0h8p5s2mj222cgcfqxmzjnfn7623d8"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/klauspost/pgzip"))
+ (propagated-inputs (list go-github-com-klauspost-compress))
+ (home-page "https://github.com/klauspost/pgzip")
+ (synopsis "Parallel (de)compression of gzip files in Go")
+ (description
+ "This package implements parallel gzip compression and decompression in
+Golang and is fully compatible with @code{compress/gzip} from the standard
+library. This is beneficial for large amounts of data, say more than 1MB at a
+time, as otherwise the internal gzip library will likely be faster.")
+ (license (list license:bsd-3 license:expat))))
+
(define-public go-github-com-nwaples-rardecode-v2
(package
(name "go-github-com-nwaples-rardecode-v2")
@@ -166,23 +193,27 @@ library included in the stdlib, and supports GIF, TIFF and PDF.")
(define-public go-github-com-ulikunitz-xz
(package
(name "go-github-com-ulikunitz-xz")
- (version "0.5.8")
+ (version "0.5.11")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/ulikunitz/xz.git")
+ (url "https://github.com/ulikunitz/xz")
(commit (string-append "v" version))))
- (file-name (string-append name "-" version "-checkout"))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1xnsymi5fmmm734bi4c6z57p5cvnyxlpi29yxs4v21w5k763aypd"))))
+ (base32 "1hbs3x7s7d5ch6ipaqi265w0fwpijs0j19xdbhbjjsyr4khxbqd0"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/ulikunitz/xz"))
+ (list
+ #:import-path "github.com/ulikunitz/xz"))
(home-page "https://github.com/ulikunitz/xz")
(synopsis "Read and write xz compressed streams in Go")
- (description "This package provides a library to read and write xz
-compressed streams in Go.")
+ (description
+ "This package provides a support of reading and writing of xz
+compressed streams. It includes also a gxz command for compressing and
+decompressing data. The package is completely written in Go and doesn't have
+any dependency on any C code.")
(license license:bsd-3)))
;;;