summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm38
1 files changed, 6 insertions, 32 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index ca35d5c391..989570c868 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -840,37 +840,6 @@ Architecture Processors\" by J. Guilford et al.")
(define-public go-github-com-multiformats-go-multihash
(package
(name "go-github-com-multiformats-go-multihash")
- (version "0.0.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/multiformats/go-multihash")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1aw4ra22g3l98bk7c3h1n968vi5a3gk528g4byj3xig76r0r731n"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/multiformats/go-multihash"))
- (propagated-inputs
- (list go-github-com-gxed-hashland-keccakpg
- go-github-com-gxed-hashland-murmur3
- go-github-com-minio-blake2b-simd
- go-github-com-minio-sha256-simd
- go-github-com-mr-tron-base58
- go-golang-org-x-crypto))
- (home-page "https://github.com/multiformats/go-multihash")
- (synopsis "Multihash implementation in Go")
- (description "Multihash implementation in Go.")
- (license license:expat)))
-
-;; XXX: Remove it when all dependent packages are ready to be updated.
-(define-public go-github-com-multiformats-go-multihash-0.2.3
- (package
- (inherit go-github-com-multiformats-go-multihash)
- (name "go-github-com-multiformats-go-multihash")
(version "0.2.3")
(source
(origin
@@ -881,6 +850,7 @@ Architecture Processors\" by J. Guilford et al.")
(file-name (git-file-name name version))
(sha256
(base32 "0ydh94083888xl2r4d1grzgqf3c818mkmdpj008jkh6h7m56wc4w"))))
+ (build-system go-build-system)
(arguments
(list #:go go-1.21
#:import-path "github.com/multiformats/go-multihash"
@@ -909,7 +879,11 @@ Architecture Processors\" by J. Guilford et al.")
go-github-com-multiformats-go-varint
go-github-com-spaolacci-murmur3
go-golang-org-x-crypto
- go-lukechampine-com-blake3))))
+ go-lukechampine-com-blake3))
+ (home-page "https://github.com/multiformats/go-multihash")
+ (synopsis "Multihash implementation in Go")
+ (description "Multihash implementation in Go.")
+ (license license:expat)))
(define-public go-github-com-operatorfoundation-ed25519
(let ((commit "b22b4bd3ddef042eec45f3ee135cd40281fde2b4")