summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index f9e7039707..0480f648eb 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1,9 +1,10 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
-;;; Copyright © 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;;
@@ -139,6 +140,31 @@ the parse trees produced by the html package.")
(description "This package provides a CSS3 tokenizer.")
(license license:bsd-3)))
+(define-public go-github-com-gorilla-handlers
+ (package
+ (name "go-github-com-gorilla-handlers")
+ (version "1.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorilla/handlers")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15gycdz9lkjnsvvichsbdf25vf6pi1sfn41khhz53iqf300l0w0s"))))
+ (build-system go-build-system)
+ (propagated-inputs
+ `(("github.com/felixge/httpsnoop" ,go-github-com-felixge-httpsnoop)))
+ (arguments
+ '(#:tests? #f ; Tries to download from the internet
+ #:import-path "github.com/gorilla/handlers"))
+ (home-page "https://github.com/gorilla/handlers")
+ (synopsis "Middleware for Go HTTP services and web applications")
+ (description "A collection of useful middleware for Go HTTP services and
+web applications.")
+ (license license:bsd-3)))
+
(define-public go-github-com-gorilla-mux
(package
(name "go-github-com-gorilla-mux")