summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm282
1 files changed, 258 insertions, 24 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ca78f7c229..daceaebb17 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -857,7 +857,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(package
(inherit go-1.18)
(name "go")
- (version "1.19.5")
+ (version "1.19.7")
(source
(origin
(method git-fetch)
@@ -867,7 +867,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(file-name (git-file-name name version))
(sha256
(base32
- "0ah4l01h8qj0vj9668bdgr5m69fq16dz1fjlj332vhysxc6bkc27"))))
+ "0rrpfhv6vdwqs0jnld0iqsky5wlirir05czf34kvsf2db21nzdi9"))))
(arguments
(substitute-keyword-arguments (package-arguments go-1.18)
((#:phases phases)
@@ -884,7 +884,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(package
(inherit go-1.19)
(name "go")
- (version "1.20")
+ (version "1.20.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -893,7 +893,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(file-name (git-file-name name version))
(sha256
(base32
- "0a7wjzv14kaqg5l7ambv5zj4rj7sgah9yhcg6k6da6ygm6bs4dv3"))))
+ "0ir0x17i9067i48ffskwlmbx1j4kfhch46zl8cwl88y23aw59qa2"))))
(native-inputs
;; Go 1.20 and later requires Go 1.17 as the bootstrap toolchain.
;; See 'src/cmd/dist/notgo117.go' in the source code distribution,
@@ -1158,6 +1158,183 @@ form that bypasses network filtering, allowing the application to work on
networks where it would otherwise be blocked or heavily throttled.")
(license license:expat)))
+(define-public go-github-com-hanwen-go-fuse-v2
+ (let ((commit "915cf5413cdef5370ae3f953f8eb4cd9ac176d5c")
+ (revision "0"))
+ (package
+ (name "go-github-com-hanwen-go-fuse-v2")
+ (version (git-version "2.2.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hanwen/go-fuse")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ik0yvs9m40vxccpb0rpxc22fyqmcgyysc7w0yl9kn3jyr6qa1d5"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/hanwen/go-fuse/v2"))
+ (native-inputs (list
+ go-golang-org-x-sys
+ go-golang-org-x-sync
+ go-github-com-kylelemons-godebug))
+ (home-page "https://github.com/hanwen/go-fuse")
+ (synopsis "Go bindings for FUSE filesystems")
+ (description
+ "This is a repository containing Go bindings for writing FUSE file systems.")
+ (license license:bsd-3))))
+
+(define-public go-github-com-aperturerobotics-jacobsa-crypto
+ (let ((commit "b1eb679742a8deed015a4406384eea6bd985d08a")
+ (revision "0"))
+ (package
+ (name "go-github-com-aperturerobotics-jacobsa-crypto")
+ (version (git-version "1.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aperturerobotics/jacobsa-crypto")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16dxigj8m6q18xqsy72iq287rh4fw0y0b9yqlw0qkclb8379n1z2"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/aperturerobotics/jacobsa-crypto"
+ ;; Source-only package.
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Source-only package.
+ (delete 'build))))
+ (home-page "https://github.com/aperturerobotics/jacobsa-crypto")
+ (synopsis "Cryptography missing from the Go standard library")
+ (description
+ "This repository contains Go packages related to cryptographic standards that are
+not included in the Go standard library.")
+ (license license:asl2.0))))
+
+(define-public go-github-com-jacobsa-oglematchers
+ (let ((commit "141901ea67cd4769c6800aa7bfdfc558fa22bda5")
+ (revision "0"))
+ (package
+ (name "go-github-com-jacobsa-oglematchers")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jacobsa/oglematchers")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09ff5x6vbhd9zl1z4yzyk573ifh16rry38q1rx986kbz4hqkmniq"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jacobsa/oglematchers"
+ ;; break loop with with go-github-com-jacobsa-ogletest
+ #:tests? #f))
+ (home-page "https://github.com/jacobsa/oglematchers")
+ (synopsis "Matchers for Go testing framework")
+ (description
+ "Package oglematchers provides a set of matchers useful in a testing or mocking
+framework. These matchers are inspired by and mostly compatible with Google
+Test for C++ and Google JS Test.")
+ (license license:asl2.0))))
+
+(define-public go-github-com-jacobsa-oglemock
+ (let ((commit "e94d794d06ffc6de42cb19d0dab3c219efdd6dcf")
+ (revision "0"))
+ (package
+ (name "go-github-com-jacobsa-oglemock")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jacobsa/oglemock")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14yxf8ykwdwkcccksl6741xgzcf8qykyi58kp4maxpgscqhdl8rq"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jacobsa/oglemock"
+ ;; break loop with with go-github-com-jacobsa-ogletest
+ #:tests? #f))
+ (native-inputs (list
+ go-github-com-jacobsa-oglematchers))
+ (home-page "https://github.com/jacobsa/oglemock")
+ (synopsis "Mocking framework for unit tests")
+ (description
+ "Package oglemock provides a mocking framework for unit tests.")
+ (license license:asl2.0))))
+
+(define-public go-github-com-jacobsa-ogletest
+ (let ((commit "80d50a735a1108a2aeb7abc4a988d183f20c5292")
+ (revision "0"))
+ (package
+ (name "go-github-com-jacobsa-ogletest")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jacobsa/ogletest")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lbwbxzr75g65q07ry5k4kglxqs3ym7xkvqznzm55rm3qk76v83r"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jacobsa/ogletest"
+ ;; These tests should be made working
+ #:tests? #f))
+ (native-inputs (list
+ go-github-com-jacobsa-oglematchers
+ go-github-com-jacobsa-oglemock
+ go-github-com-jacobsa-reqtrace
+ go-golang-org-x-net))
+ (home-page "https://github.com/jacobsa/ogletest")
+ (synopsis "Expressive unit tests")
+ (description
+ "Package ogletest provides a framework for writing expressive unit tests. It
+integrates with the builtin testing package, so it works with the gotest
+command. Unlike the testing package which offers only basic capabilities for
+signalling failures, it offers ways to express expectations and get nice failure
+messages automatically.")
+ (license license:asl2.0))))
+
+(define-public go-github-com-jacobsa-reqtrace
+ (let ((commit "245c9e0234cb2ad542483a336324e982f1a22934")
+ (revision "0"))
+ (package
+ (name "go-github-com-jacobsa-reqtrace")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jacobsa/reqtrace")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zfyijig10896v42rvxka1n4wn6lijqz40y2281187l7mq8vv5jn"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jacobsa/reqtrace"))
+ (inputs (list
+ go-golang-org-x-net))
+ (home-page "https://github.com/jacobsa/reqtrace")
+ (synopsis "Simple request tracing framework")
+ (description
+ "Package reqtrace contains a very simple request tracing framework.")
+ (license license:asl2.0))))
+
(define-public go-github-com-kataras-golog
(package
(name "go-github-com-kataras-golog")
@@ -1229,6 +1406,59 @@ terminals.")
aid data snapshotting.")
(license license:isc)))
+(define-public go-github-com-pkg-xattr
+ (package
+ (name "go-github-com-pkg-xattr")
+ (version "0.4.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pkg/xattr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qg4zh0d8m4adaiicsd0cpw0w6g8sk01f4jz7jyxgirh1wfcsqyz"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/pkg/xattr"))
+ (native-inputs (list go-golang-org-x-sys))
+ (home-page "https://github.com/pkg/xattr")
+ (synopsis "Support for extended file system attributes")
+ (description
+ "Package xattr provides support for extended attributes on Linux, Darwin and
+FreeBSD. Extended attributes are name:value pairs permanently associated with
+files or directories. They are similar to the environment strings associated with
+a process. An attribute may be defined or undefined. If defined, its value may
+be empty or non-empty. You can find more details here:
+@@url{https://en.wikipedia.org/wiki/Extended_file_attributes,
+https://en.wikipedia.org/wiki/Extended_file_attributes}
+.")
+ (license license:bsd-2)))
+
+(define-public go-github-com-rfjakob-eme
+ (package
+ (name "go-github-com-rfjakob-eme")
+ (version "1.1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rfjakob/eme")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yrbhvy0337mf12fp8p4sy8ry8r3w2qfdf8val5hj07p2lri0cqk"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/rfjakob/eme"))
+ (home-page "https://github.com/rfjakob/eme")
+ (synopsis "EME for Go")
+ (description
+ "EME (ECB-Mix-ECB or, clearer, Encrypt-Mix-Encrypt) is a wide-block encryption
+mode developed by Halevi and Rogaway.")
+ (license license:expat)))
+
(define-public go-github-com-shadowsocks-go-shadowsocks2
(package
(name "go-github-com-shadowsocks-go-shadowsocks2")
@@ -3118,11 +3348,11 @@ the official package.")
(license license:bsd-3)))
(define-public go-golang-org-x-net
- (let ((commit "ba9fcec4b297b415637633c5a6e8fa592e4a16c3")
- (revision "4"))
+ (let ((commit "8e0e7d8d38f2b6d21d742845570dde2902d06a1d")
+ (revision "0"))
(package
(name "go-golang-org-x-net")
- (version (git-version "0.0.0" revision commit))
+ (version (git-version "0.5.0" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3131,15 +3361,17 @@ the official package.")
(file-name (git-file-name name version))
(sha256
(base32
- "1hbqvy6r0s5h0dpdqw8fynl3cq0acin3iyqki9xvl5r8h33yb9bx"))))
+ "1fidlcn3vcz42v2lc0rpmqh3bz08bcklj6jvnmz2vvgc481ci5hy"))))
(build-system go-build-system)
(arguments
- `(#:import-path "golang.org/x/net"
- ; Source-only package
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'build))))
+ (list
+ #:import-path "golang.org/x/net"
+ ;; Source-only package
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Source-only package
+ (delete 'build))))
(synopsis "Go supplemental networking libraries")
(description "This package provides supplemental Go networking libraries.")
(home-page "https://go.googlesource.com/net")
@@ -3218,11 +3450,11 @@ packages.")
(license license:bsd-3))))
(define-public go-golang-org-x-sys
- (let ((commit "ed5796bab16455f104b6a384d51b7f9990cb9806")
- (revision "8"))
+ (let ((commit "b60007cc4e6f966b1c542e343d026d06723e5653")
+ (revision "0"))
(package
(name "go-golang-org-x-sys")
- (version (git-version "0.0.0" revision commit))
+ (version (git-version "0.4.0" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3231,15 +3463,17 @@ packages.")
(file-name (git-file-name name version))
(sha256
(base32
- "081vs5bg91mwg5bdmlcvy2qyrvg766aicj47smcwfk4bbh0nc0qa"))))
+ "0fr2d6fnpbqx6n89sg9lsinqkdaw49y068kqj2g0cxlhbh69hzii"))))
(build-system go-build-system)
(arguments
- `(#:import-path "golang.org/x/sys"
- ;; Source-only package
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'build))))
+ (list
+ #:import-path "golang.org/x/sys"
+ ;; Source-only package
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Source-only package
+ (delete 'build))))
(synopsis "Go support for low-level system interaction")
(description "This package provides supplemental libraries offering Go
support for low-level interaction with the operating system.")