summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm40
1 files changed, 0 insertions, 40 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1a02f66ac8..e79179679c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11304,46 +11304,6 @@ non-cryptographic hash algorithm, working at speeds close to RAM limits.")
anti-fragmentation protection.")
(license license:expat)))
-(define-public go-github-com-valyala-fasthttp
- (package
- (name "go-github-com-valyala-fasthttp")
- (version "1.39.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/valyala/fasthttp")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "12qwx0yk7wjj25v4fswgmj28r69gk94kqdmzavca8k9f0yznniz1"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/valyala/fasthttp"
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
- (unless
- ;; Tests hang forever with gccgo.
- (false-if-exception (search-input-file inputs "/bin/gccgo"))
- (apply (assoc-ref %standard-phases 'check) args)))))))
- (propagated-inputs
- (list go-golang-org-x-sys
- go-golang-org-x-net
- go-golang-org-x-crypto
- go-github-com-valyala-tcplisten
- go-github-com-valyala-bytebufferpool
- go-github-com-klauspost-compress
- go-github-com-andybalholm-brotli))
- (home-page "https://github.com/valyala/fasthttp")
- (synopsis "Provides fast HTTP server and client API")
- (description
- "This package provides a Go module @code{fasthttp} which may be used as
-replacement for native @code{net/http} module.")
- (license license:expat)))
-
(define-public go-github-com-valyala-tcplisten
(package
(name "go-github-com-valyala-tcplisten")