summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 91e14ae1a3..b7a376c15f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8469,17 +8469,9 @@ Gemini clients and servers.")
"1lpqw7ygffak8qki9i4vw8b99l25l8jrw8iwcplqsclk6fzkl24p"))))
(build-system go-build-system)
(arguments
- '(#:tests? #f
- #:import-path "go.uber.org/goleak"))
- (propagated-inputs
- (list go-github-com-davecgh-go-spew
- go-github-com-kr-pretty
- go-github-com-pmezard-go-difflib
- go-github-com-stretchr-testify
- go-golang-org-x-lint
- go-golang-org-x-tools
- go-gopkg-in-check-v1
- go-gopkg-in-yaml-v3))
+ '(#:import-path "go.uber.org/goleak"))
+ (native-inputs
+ (list go-github-com-stretchr-testify-next))
(home-page "https://go.uber.org/goleak")
(synopsis "Goroutine leak detector")
(description "Go package to verify that there are no unexpected goroutines