summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm33
1 files changed, 0 insertions, 33 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6a244152d5..f2084dfc4b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5971,39 +5971,6 @@ implementation of generics.")
(home-page "https://github.com/cheekybits/genny/")
(license license:expat)))
-(define-public go-github-com-quic-go-qpack
- (package
- (name "go-github-com-quic-go-qpack")
- (version "0.4.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/quic-go/qpack")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "00mjz445hhx4yar5l8p21bpp4d06jyg2ajw0ax7bh64d37l4kx39"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/quic-go/qpack"
- ;; Tests require ginkgo v2.
- #:tests? #f
- #:go go-1.20))
- (propagated-inputs (list go-github-com-onsi-gomega
- go-github-com-onsi-ginkgo
- go-golang-org-x-net))
- (synopsis "Minimal QPACK (RFC 9204) implementation for Go")
- (description
- "A minimal QPACK (RFC 9204) implementation in Go. It is minimal in the sense
-that it doesn't use the dynamic table at all, but just the static table and (Huffman
-encoded) string literals. Wherever possible, it reuses code from the
-@url{https://github.com/golang/net/tree/master/http2/hpack, HPACK implementation in
-the Go standard library}.")
- (home-page "https://github.com/quic-go/qpack")
- (license license:expat)))
-
(define-public go-github-com-quic-go-quic-go
(package
(name "go-github-com-quic-go-quic-go")