summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm114
1 files changed, 47 insertions, 67 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ebf571d93e..6c2eb1f26e 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -313,60 +313,54 @@ objects!")
(license license:lgpl2.1+)))
(define-public autotrace
- (let ((commit "travis-20190624.59")
- (version-base "0.40.0"))
- (package
- (name "autotrace")
- (version (string-append version-base "-"
- (if (string-prefix? "travis-" commit)
- (string-drop commit 7)
- commit)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/autotrace/autotrace")
- (commit commit)))
- (file-name (git-file-name name version))
- (patches (search-patches "autotrace-glib-compat.patch"))
- (sha256
- (base32
- "0mk4yavy42dj0pszr1ggnggpvmzs4ds46caa9wr55cqsypn7bq6s"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- ;; See: https://github.com/autotrace/autotrace/issues/27.
- (add-after 'unpack 'include-spline.h-header
- (lambda _
- (substitute* "Makefile.am"
- ((".*src/types.h.*" all)
- (string-append all "\t\tsrc/spline.h \\\n")))
- #t))
- ;; See: https://github.com/autotrace/autotrace/issues/26.
- (replace 'check
- (lambda _
- (invoke "sh" "tests/runtests.sh"))))))
- (native-inputs
- `(("which" ,which)
- ("pkg-config" ,pkg-config)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("intltool" ,intltool)
- ("libtool" ,libtool)
- ("gettext" ,gettext-minimal)))
- (inputs
- `(("glib" ,glib)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("imagemagick" ,imagemagick)
- ("pstoedit" ,pstoedit)))
- (home-page "https://github.com/autotrace/autotrace")
- (synopsis "Bitmap to vector graphics converter")
- (description "AutoTrace is a utility for converting bitmap into vector
+ (package
+ (name "autotrace")
+ (version "0.31.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/autotrace/autotrace")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fsg13pg72ac51l3fkzvyf7h9mzbvfxp9vfjfiwkyvx6hbm83apj"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:configure-flags #~'("--disable-static")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-pkg-config-file
+ (lambda _
+ ;; autotrace can be built against either GraphicsMagick or
+ ;; ImageMagick. However the pkg-config file refers to
+ ;; non-existent MAGICK_ variables instead of GRAPHICSMAGICK_
+ ;; or IMAGEMAGICK_; fix that.
+ (substitute* "autotrace.pc.in"
+ (("@MAGICK_(LIBS|CFLAGS)@" _ var)
+ (string-append "@IMAGEMAGICK_" var "@"))))))))
+ (native-inputs
+ (list which
+ autoconf
+ automake
+ libtool
+ intltool
+ pkg-config
+ procps)) ;for tests
+ (inputs
+ (list glib
+ imagemagick
+ libjpeg-turbo
+ libpng
+ pstoedit))
+ (home-page "https://github.com/autotrace/autotrace")
+ (synopsis "Bitmap to vector graphics converter")
+ (description "AutoTrace is a utility for converting bitmap into vector
graphics. It can trace outlines and midlines, effect color reduction or
despeckling and has support for many input and output formats. It can be used
with the @command{autotrace} utility or as a C library, @code{libautotrace}.")
- (license (list license:gpl2+ ;for the utility itself
- license:lgpl2.1+))))) ;for use as a library
+ (license (list license:gpl2+ ;for the utility itself
+ license:lgpl2.1+)))) ;for use as a library
(define-public embree
(package
@@ -824,7 +818,7 @@ exception-handling library.")
(define-public lib2geom
(package
(name "lib2geom")
- (version "1.1")
+ (version "1.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -833,7 +827,7 @@ exception-handling library.")
(file-name (git-file-name name version))
(sha256
(base32
- "03bx9k1m4bfhmx0ldsg0bks6i8h7fmvl5vbg6gmpq0bk0nkmpnmv"))))
+ "0dq981g894hmvhd6rmfl1w32mksg9hpvpjs1qvfxrnz87rhkknj8"))))
(build-system cmake-build-system)
(arguments
`(#:imported-modules ((guix build python-build-system)
@@ -890,20 +884,6 @@ basic geometries.")
;; https://gitlab.com/inkscape/inkscape/issues/784).
(license license:gpl3+)))
-(define-public lib2geom-1.2
- (package
- (inherit lib2geom)
- (version "1.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/inkscape/lib2geom")
- (commit version)))
- (file-name (git-file-name "lib2geom" version))
- (sha256
- (base32
- "0dq981g894hmvhd6rmfl1w32mksg9hpvpjs1qvfxrnz87rhkknj8"))))))
-
(define-public python-booleanoperations
(package
(name "python-booleanoperations")