summaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 3bfbcb2250..dbfc66960e 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -150,19 +150,20 @@ interfaces for other technical domains.")
(arguments
(substitute-keyword-arguments (package-arguments graphviz)
((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'prepare-bootstrap
- (lambda _
- (substitute* "autogen.sh"
- (("/bin/sh") (which "sh"))
- (("\\$GRAPHVIZ_VERSION_DATE") "0"))
- (setenv "CONFIG_SHELL" (which "sh"))
- (setenv "SHELL" (which "sh"))
+ #~(modify-phases #$phases
+ (add-after 'unpack 'prepare-bootstrap
+ (lambda _
+ (substitute* "autogen.sh"
+ (("/bin/sh") (which "sh"))
+ (("\\$GRAPHVIZ_VERSION_DATE") "0"))
+ (setenv "CONFIG_SHELL" (which "sh"))
+ (setenv "SHELL" (which "sh"))
- (map make-file-writable (find-files "." ".*"))
- #t))
- (replace 'bootstrap
- (lambda _ (invoke (which "sh") "autogen.sh" "NOCONFIG") #t))))))
+ (map make-file-writable (find-files "." ".*"))
+ #t))
+ (replace 'bootstrap
+ (lambda _
+ (invoke (which "sh") "autogen.sh" "NOCONFIG") #t))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)