summaryrefslogtreecommitdiff
path: root/gnu/packages/grub.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/grub.scm')
-rw-r--r--gnu/packages/grub.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/grub.scm b/gnu/packages/grub.scm
index b920be9ea2..ef7395e95e 100644
--- a/gnu/packages/grub.scm
+++ b/gnu/packages/grub.scm
@@ -127,9 +127,16 @@
(("set -e") "exit 77\nset -e"))
#t)))))
(inputs
- `(;; ("lvm2" ,lvm2)
- ("gettext" ,gettext-minimal)
+ `(("gettext" ,gettext-minimal)
+
+ ;; Depend on LVM2 for libdevmapper, used by 'grub-probe' and
+ ;; 'grub-install' to recognize mapped devices (LUKS, etc.)
+ ("lvm2" ,lvm2)
+
+ ;; Depend on mdadm, which is invoked by 'grub-probe' and 'grub-install'
+ ;; to determine whether the root file system is RAID.
("mdadm" ,mdadm)
+
("freetype" ,freetype)
;; ("libusb" ,libusb)
;; ("fuse" ,fuse)