summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm45
1 files changed, 44 insertions, 1 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 7478dc3188..58625be073 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -21,12 +21,14 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
#:use-module (gnu packages bison)
#:use-module (gnu packages flex)
#:use-module (gnu packages glib)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages python))
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages xml))
(define-public gstreamer
(package
@@ -64,6 +66,30 @@ simple plugin with a clean, generic interface.
This package provides the core library and elements.")
(license lgpl2.0+)))
+(define-public gstreamer-0.10
+ (package (inherit gstreamer)
+ (version "0.10.36")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1nkid1n2l3rrlmq5qrf5yy06grrkwjh3yxl5g0w58w0pih8allci"))
+ (patches
+ (list (search-patch "gstreamer-0.10-bison3.patch")
+ (search-patch "gstreamer-0.10-silly-test.patch")))))
+ (propagated-inputs
+ `(("libxml2" ,libxml2)))
+ (inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)
+ ("glib" ,glib)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-2)))))
+
(define-public gst-plugins-base
(package
(name "gst-plugins-base")
@@ -107,3 +133,20 @@ simple plugin with a clean, generic interface.
This package provides an essential exemplary set of elements.")
(license lgpl2.0+)))
+
+(define-public gst-plugins-base-0.10
+ (package (inherit gst-plugins-base)
+ (version "0.10.36")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0jp6hjlra98cnkal4n6bdmr577q8mcyp3c08s3a02c4hjhw5rr0z"))))
+ (inputs
+ `(("glib" ,glib)
+ ("gstreamer" ,gstreamer-0.10)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-2)))))