summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 5b88a9d31e..848ed91d96 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -401,12 +401,15 @@ applications.")
(list bash-minimal
zlib))
(native-inputs
- (list `(,glib "bin") ;glib-mkenums, etc.
- gobject-introspection ;g-ir-compiler, etc.
- help2man
- perl
- pkg-config
- python-wrapper))
+ (append (list `(,glib "bin")) ;glib-mkenums, etc.
+ (if (target-hurd?)
+ '()
+ (list gobject-introspection)) ;g-ir-compiler, etc.
+ (list
+ help2man
+ perl
+ pkg-config
+ python-wrapper)))
(synopsis "Text and font handling library")
(description "Pango is a library for laying out and rendering of text, with
an emphasis on internationalization. Pango can be used anywhere that text