summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 24089668d2..eb1984fb20 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -943,13 +943,13 @@ exceptions, macros, and a dynamic programming environment.")
(version (string-append "2.18.1-" revision "."
(string-take commit 7)))
(source (origin
- (method url-fetch)
- (uri (string-append "https://gitlab.com/wingo/guile-rsvg/"
- "repository/archive.tar.gz?ref="
- commit))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/wingo/guile-rsvg/")
+ (commit commit)))
(sha256
(base32
- "0vdzjx8l5nc4y2xjqs0g1rqn1zrwfsm30brh5gz00r1x41a2pvv2"))
+ "0cnbl40df2sbhpc32cma6j6w312rfvcgbxxqaixgf0ymim3fb248"))
(patches (search-patches "guile-rsvg-pkgconfig.patch"))
(modules '((guix build utils)))
(snippet