summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index dad1944b1a..ca41612e90 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -705,8 +705,10 @@ highlighting and other features typical of a source code editor.")
(modify-phases %standard-phases
(add-before 'configure 'disable-failing-tests
(lambda _
- (substitute* "tests/meson.build"
- (("\\[ 'pixbuf-fail', \\['conform', 'slow'\\], \\],")
+ ;; The test for the fix for issue 205 causes failures.
+ ;; https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/issues/215
+ (substitute* "tests/pixbuf-jpeg.c"
+ ((".*/pixbuf/jpeg/issue205.*")
""))))
;; The slow tests take longer than the specified timeout.
,@(if (target-arm? (%current-system))