summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm29
1 files changed, 27 insertions, 2 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index af032db680..557589d2bb 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1373,6 +1373,31 @@ non-mutating insert, delete, and search operations, with support for
convenient nested tree operations.")
(license license:gpl3+)))
+(define-public guile-algorithms
+ (package
+ (name "guile-algorithms")
+ (version "0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git@git.sr.ht/~filiplajszczak/guile-algorithms")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1a4ffnnhw92gqphjji5ajy3xfaqzww7xv3h8p82gkawx0rqvj5ni"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake pkg-config texinfo))
+ (inputs (list guile-3.0))
+ (synopsis "Guile port of racket-algorithms")
+ (description
+ "Guile port of @url{https://docs.racket-lang.org/algorithms/index.html,
+racket-algorithms}, a package containing useful algorithms borrowed from other
+programming languages).")
+ (home-page "https://guile-algorithms.lajszczak.dev/")
+ (license license:gpl3+)))
+
(define-public guile-aws
(let ((commit "f32bea12333e1054b97ab50e58a72636edabb5b7")
(revision "1"))
@@ -4593,7 +4618,7 @@ according to Bitorrent BEP003.")
(define-public guile-ts
(package
(name "guile-ts")
- (version "0.1.0")
+ (version "0.2.0")
(source (origin (method git-fetch)
(uri (git-reference
(url
@@ -4602,7 +4627,7 @@ according to Bitorrent BEP003.")
(file-name (git-file-name name version))
(sha256
(base32
- "0xmq2d3mv921m0g1hqw6bjzh4m622g2c7pal11ks7vjn0m8d4bxj"))))
+ "1iqbr9rcpmq2f1zxxvl36ajwm81rkp38rrp42ixr4q59154r5513"))))
(build-system gnu-build-system)
(arguments
(list #:make-flags #~(list "GUILE_AUTO_COMPILE=0")