summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm27
1 files changed, 17 insertions, 10 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index c4d6d38b9b..b161d335ba 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1190,9 +1190,7 @@ messaging library.")
;; command.
(substitute* "src/hmac.scm"
(("openssl")
- (string-append (assoc-ref inputs "openssl")
- "/bin/openssl")))
- #t))
+ (search-input-file inputs "/bin/openssl")))))
;; XXX: The code uses 'include' to include its own source
;; files, and "-L src" isn't enough in this case.
@@ -1314,7 +1312,9 @@ tracker's SOAP service, such as @url{https://bugs.gnu.org}.")
version ".tar.lz"))
(sha256
(base32
- "1rc8r0fgvflnyq5ckl7ii8sghpsgpkzxa8vskjr1ak2kyar6m35k"))))
+ "1rc8r0fgvflnyq5ckl7ii8sghpsgpkzxa8vskjr1ak2kyar6m35k"))
+ (patches
+ (search-patches "guile-email-fix-tests.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -2989,7 +2989,7 @@ chunks can be expressions as well as simple tokens.")
(("/usr/local/lib/guile")
(string-append (assoc-ref outputs "out") "/lib/guile"))
(("/usr/local/include/guile")
- (string-append (assoc-ref inputs "guile") "/include/guile"))
+ (search-input-directory inputs "/include/guile"))
(("-L/usr/local/lib")
(string-append "-L" (assoc-ref inputs "guile") "/lib")))
#t))
@@ -3388,7 +3388,7 @@ API.")
("perl" ,perl)
("pkg-config" ,pkg-config)
("texinfo" ,texinfo)
- ("texlive" ,(texlive-union (list texlive-generic-epsf)))))
+ ("texlive" ,(texlive-updmap.cfg (list texlive-epsf)))))
(inputs
`(("dbus-glib" ,dbus-glib)
("guile" ,guile-3.0)
@@ -3672,7 +3672,7 @@ feature-set, fully programmable in Guile Scheme.")
("vigra-c" ,vigra-c)
("guile" ,guile-2.2)))
(native-inputs
- `(("texlive" ,(texlive-union (list texlive-booktabs
+ `(("texlive" ,(texlive-updmap.cfg (list texlive-booktabs
texlive-lm
texlive-siunitx
texlive-standalone
@@ -4066,7 +4066,14 @@ over, or update a value in arbitrary data structures.")
(file-name (git-file-name name version))
(sha256
(base32
- "16k61f1jn3g48jaf3730b9l0izr5j933jzyri73nmcnjd09gm35i"))))
+ "16k61f1jn3g48jaf3730b9l0izr5j933jzyri73nmcnjd09gm35i"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Guile >= 3.0.7 no longer uses libltdl so we need to explicitly add
+ ;; ".libs" so that 'load-extension' finds the '.so' file.
+ '(substitute* "pre-inst-env.in"
+ (("^LD_LIBRARY_PATH=.*$")
+ "LD_LIBRARY_PATH=\"$abs_top_builddir/.libs\"\n")))))
(build-system gnu-build-system)
(arguments
'(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ; to prevent guild warnings
@@ -4737,8 +4744,8 @@ schedulers.")
"yaml/libyaml.scm"
;; This file is mismatched with the generated FFI code.
"yaml/ffi-help-rt.scm"))
- (copy-file (string-append (assoc-ref inputs "nyacc")
- "/share/guile/site/3.0/system/ffi-help-rt.scm")
+ (copy-file (search-input-file
+ inputs "/share/guile/site/3.0/system/ffi-help-rt.scm")
"yaml/ffi-help-rt.scm")
(substitute* "yaml/ffi-help-rt.scm"
(("system ffi-help-rt") "yaml ffi-help-rt"))