summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 28c2dacad8..a4c1ba2544 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13146,6 +13146,25 @@ and high speed.")
(native-inputs '())
(properties '((hidden? #t)))))
+(define-public ghc-commutative-semigroups
+ (package
+ (name "ghc-commutative-semigroups")
+ (version "0.1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "commutative-semigroups" version))
+ (sha256
+ (base32
+ "1bmafx363gfsd9wwrf3xyrw9mnw6anmc1zdfv0p8597y4lxxach7"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "commutative-semigroups")))
+ (home-page "http://hackage.haskell.org/package/commutative-semigroups")
+ (synopsis "Commutative semigroups")
+ (description
+ "This package provides a commutative semigroup is a semigroup where the order of
+arguments to mappend does not matter.")
+ (license license:bsd-3)))
+
(define-public ghc-unsafe
(package
(name "ghc-unsafe")