summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8e3164439e..759d223a42 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3088,4 +3088,40 @@ and any other types of tests into a single test suite.")
test framework.")
(license expat)))
+(define-public ghc-scientific
+ (package
+ (name "ghc-scientific")
+ (version "0.3.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/scientific/scientific-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0mimdkva0cgzaychr6whv9if29z0r5wwhkss9bmd4rz8kq1kgngn"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-hashable" ,ghc-hashable)
+ ("ghc-vector" ,ghc-vector)))
+ (inputs
+ `(("ghc-text" ,ghc-text)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-ant-xml" ,ghc-tasty-ant-xml)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-smallcheck" ,ghc-tasty-smallcheck)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+ ("ghc-smallcheck" ,ghc-smallcheck)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "https://github.com/basvandijk/scientific")
+ (synopsis "Numbers represented using scientific notation")
+ (description "This package provides @code{Data.Scientific}, which provides
+the number type @code{Scientific}. Scientific numbers are arbitrary precision
+and space efficient. They are represented using
+@uref{http://en.wikipedia.org/wiki/Scientific_notation, scientific
+notation}.")
+ (license bsd-3)))
+
;;; haskell.scm ends here