summaryrefslogtreecommitdiff
path: root/gnu/packages/high-availability.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/high-availability.scm')
-rw-r--r--gnu/packages/high-availability.scm50
1 files changed, 48 insertions, 2 deletions
diff --git a/gnu/packages/high-availability.scm b/gnu/packages/high-availability.scm
index eccdb3594e..b0e6631389 100644
--- a/gnu/packages/high-availability.scm
+++ b/gnu/packages/high-availability.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,7 +36,12 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages golang)
+ #:use-module (gnu packages golang-build)
+ #:use-module (gnu packages golang-check)
+ #:use-module (gnu packages golang-compression)
+ #:use-module (gnu packages golang-crypto)
#:use-module (gnu packages golang-web)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages hardware)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
@@ -45,7 +51,6 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages rsync)
- #:use-module (gnu packages syncthing)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages version-control)
@@ -194,6 +199,47 @@ applications.")
in general better performances compared to the old network protocol.")
(license (list license:gpl2+ license:lgpl2.1+))))
+(define-public nats-server
+ (package
+ (name "nats-server")
+ (version "2.10.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nats-io/nats-server")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sn8a3xfs1s9jc5fphrnc0ahh83h7ma2ckg2x447gdhg1p7pf9gn"))))
+ (build-system go-build-system)
+ (inputs
+ (list go-github-com-klauspost-compress
+ go-github-com-minio-highwayhash
+ go-github-com-nats-io-jwt-v2
+ go-github-com-nats-io-nats-go
+ go-github-com-nats-io-nkeys
+ go-github-com-nats-io-nuid
+ go-go-uber-org-automaxprocs
+ go-golang-org-x-crypto
+ go-golang-org-x-sys
+ go-golang-org-x-time))
+ (arguments
+ (list
+ #:go go-1.20
+ #:import-path "github.com/nats-io/nats-server"
+ #:install-source? #f))
+ (home-page "https://github.com/nats-io/nats-server")
+ (synopsis "High performance message broker")
+ (description
+ "NATS is a simple, secure and performant communications system for digital
+systems, services and devices. NATS is part of the Cloud Native Computing
+Foundation (CNCF). NATS has over 40 client language implementations, and its
+server can run on-premise, in the cloud, at the edge, and even on a Raspberry
+Pi. NATS can secure and simplify design and operation of modern distributed
+systems.")
+ (license license:asl2.0)))
+
(define-public nsq
(package
(name "nsq")
@@ -240,7 +286,7 @@ applications.")
go-github-com-bmizerany-perks-quantile
go-github-com-burntsushi-toml
go-github-com-davecgh-go-spew
- go-github-com-golang-snappy ; Move to (gnu packages golang)
+ go-github-com-golang-snappy
go-github-com-julienschmidt-httprouter
go-github-com-mreiferson-go-options
go-github-com-mreiferson-go-svc