summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm48
1 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 59a7b55943..f30192961c 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016, 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
-;;; Copyright © 2018, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2018, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
@@ -51,20 +51,16 @@
hurd-target?
hurd-triplet?))
-(define (hurd-triplet? triplet)
- (and (string-suffix? "-gnu" triplet)
- (not (string-contains triplet "linux"))))
-
(define (hurd-target?)
"Return true if the cross-compilation target or the current system is
GNU/Hurd."
- (or (and=> (%current-target-system) hurd-triplet?)
+ (or (and=> (%current-target-system) target-hurd?)
(and (not (%current-target-system))
- (and=> (%current-system) hurd-triplet?))))
+ (and=> (%current-system) target-hurd?))))
(define (hurd-system?)
"Return true if the current system is the Hurd."
- (and=> (%current-system) hurd-triplet?))
+ (and=> (%current-system) target-hurd?))
(define (hurd-source-url version)
(string-append "mirror://gnu/hurd/hurd-"
@@ -305,6 +301,8 @@ Hurd-minimal package which are needed for both glibc and GCC.")
(name "gnumach")
(arguments
(substitute-keyword-arguments (package-arguments gnumach-headers)
+ ((#:make-flags flags ''())
+ `(cons "CFLAGS=-fcommon" ,flags))
((#:configure-flags flags ''())
`(cons "--enable-kdb" ,flags)) ;enable kernel debugger
((#:phases phases '%standard-phases)
@@ -314,8 +312,7 @@ Hurd-minimal package which are needed for both glibc and GCC.")
(let* ((out (assoc-ref outputs "out"))
(boot (string-append out "/boot")))
(invoke "make" "gnumach.gz")
- (install-file "gnumach.gz" boot)
- #t)))))))
+ (install-file "gnumach.gz" boot))))))))
(native-inputs
`(("mig" ,mig)
("perl" ,perl)
@@ -378,9 +375,10 @@ Hurd-minimal package which are needed for both glibc and GCC.")
(lambda* (#:key inputs #:allow-other-keys)
(for-each (lambda (var)
(setenv var
- (string-append (assoc-ref inputs "libtirpc")
- "/include/tirpc:"
- (or (getenv var) ""))))
+ (string-append
+ (search-input-directory inputs
+ "include/tirpc")
+ ":" (or (getenv var) ""))))
'("CROSS_C_INCLUDE_PATH" "C_INCLUDE_PATH"
"CROSS_CPATH" "CPATH"))
#t))
@@ -510,16 +508,18 @@ exec ${system}/rc \"$@\"
(copy-file "unifont"
(string-append datadir "/vga-system.bdf"))
#t))))
- #:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
- %output "/lib")
- "--disable-ncursesw"
- "--without-libbz2"
- "--without-libz"
- "--without-parted"
- ;; This is needed to pass the configure check for
- ;; clnt_create
- "ac_func_search_save_LIBS=-ltirpc"
- "ac_cv_search_clnt_create=false")))
+ #:configure-flags
+ ,#~(list (string-append "LDFLAGS=-Wl,-rpath="
+ #$output "/lib")
+ "--disable-ncursesw"
+ "--without-libbz2"
+ "--without-libz"
+ "--without-parted"
+ ;; This is needed to pass the configure check for
+ ;; clnt_create
+ "ac_func_search_save_LIBS=-ltirpc"
+ "ac_cv_search_clnt_create=false"
+ "CFLAGS=-fcommon")))
(build-system gnu-build-system)
(inputs
`(("glibc-hurd-headers" ,glibc/hurd-headers)
@@ -589,7 +589,7 @@ implementing them.")
"LINK_PROGRAM=i586-pc-gnu-gcc")
(list "CC=gcc")))
#:configure-flags
- (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
+ ,#~(list (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))
#:phases
(modify-phases %standard-phases
(delete 'configure)