summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm102
1 files changed, 98 insertions, 4 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 05b9472395..830ce10ea6 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -1,10 +1,11 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
+;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,22 +29,29 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages base)
+ #:use-module (gnu packages boost)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages graphics)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages maths)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages xorg))
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages))
(define-public feh
(package
(name "feh")
- (version "2.18.2")
+ (version "2.18.3")
(home-page "https://feh.finalrewind.org/")
(source (origin
(method url-fetch)
@@ -51,7 +59,7 @@
name "-" version ".tar.bz2"))
(sha256
(base32
- "09f5rfzls4h5jcrp7ylwbiljp5qzc2nbw9p2csv0pnlaixj69gil"))))
+ "0qq567d0g181k6llr6p759lnni39va5xakjqngd6063fm73nhbyq"))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-delete 'configure %standard-phases)
@@ -122,6 +130,29 @@ image formats; tools for image comparison, sorting and managing photo
collection. Geeqie was initially based on GQview.")
(license license:gpl2+)))
+(define-public gpicview
+ (package
+ (name "gpicview")
+ (version "0.2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/lxde/"
+ "GPicView%20%28image%20Viewer%29/0.2.x/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0hi9v0rdx47nys0wvm9xasdrafa34r5kq6crb074a0ipwmc60iiq"))))
+ (build-system gnu-build-system)
+ (inputs `(("gtk+" ,gtk+-2)
+ ("libjpeg" ,libjpeg)))
+ (native-inputs `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Simple and fast image viewer for X")
+ (description "gpicview is a lightweight GTK+ 2.x based image viewer.
+It is the default image viewer on LXDE desktop environment.")
+ (home-page "http://lxde.sourceforge.net/gpicview/")
+ (license license:gpl2+)))
+
(define-public sxiv
(package
(name "sxiv")
@@ -266,3 +297,66 @@ your images. Among its features are:
"Catimg is a little program that prints images in the terminal.
It supports JPEG, PNG and GIF formats.")
(license license:expat)))
+
+(define-public luminance-hdr
+ (package
+ (name "luminance-hdr")
+ (version "2.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/qtpfsgui/luminance/"
+ version "/luminance-hdr-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "00fldbcizrx8jcnjgq74n3zmbm27dxzl96fxa7q49689mfnlw08l"))
+ (patches (search-patches "luminance-hdr-qt-printer.patch"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtwebkit" ,qtwebkit)
+ ("boost" ,boost)
+ ;; ("gtest" ,gtest)
+ ("libraw" ,libraw)
+ ("zlib" ,zlib)
+ ("exiv2" ,exiv2)
+ ("libpng" ,libpng)
+ ("libjpeg" ,libjpeg)
+ ("lcms" ,lcms)
+ ("openexr" ,openexr)
+ ("fftw" ,fftwf)
+ ("gsl" ,gsl)
+ ("libtiff" ,libtiff)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'set-paths 'add-ilmbase-include-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; 'OpenEXR.pc' has a -I for IlmBase but 'FindOpenEXR.cmake' does
+ ;; not use 'OpenEXR.pc'. Thus, we need to add
+ ;; "$ilmbase/include/OpenEXR/" to the CPATH.
+ (setenv "CPATH"
+ (string-append (assoc-ref inputs "ilmbase")
+ "/include/OpenEXR"
+ ":" (or (getenv "CPATH") "")))
+ #t)))))
+ (home-page "http://qtpfsgui.sourceforge.net")
+ (synopsis "High dynamic range (HDR) imaging application")
+ (description
+ "Luminance HDR (formerly QtPFSGui) is a graphical user interface
+application that aims to provide a workflow for high dynamic range (HDR)
+imaging. It supports several HDR and LDR image formats, and it can:
+
+@itemize
+@item Create an HDR file from a set of images (formats: JPEG, TIFF 8bit and
+16bit, RAW) of the same scene taken at different exposure setting;
+@item Save load HDR images;
+@item Rotate, resize and crop HDR images;
+@item Tone-map HDR images;
+@item Copy EXIF data between sets of images.
+@end itemize\n")
+ (license license:gpl2+)))