summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm73
1 files changed, 69 insertions, 4 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 0a6be77d24..dfe29d413e 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -2,12 +2,12 @@
;;; Copyright © 2013, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 nee <nee-git@hidamari.blue>
-;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019, 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
@@ -15,6 +15,7 @@
;;; Copyright © 2020 Peng Mei Yu <pengmeiyu@riseup.net>
;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2021 Rovanion Luckey <rovanion.luckey@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -58,6 +59,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages graphics)
#:use-module (gnu packages image)
+ #:use-module (gnu packages image-processing)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages maths)
#:use-module (gnu packages perl)
@@ -74,7 +76,7 @@
(define-public feh
(package
(name "feh")
- (version "3.6.1")
+ (version "3.6.2")
(home-page "https://feh.finalrewind.org/")
(source (origin
(method url-fetch)
@@ -82,7 +84,7 @@
name "-" version ".tar.bz2"))
(sha256
(base32
- "1a0ygdpyvpcsr0hdi9ai7ycbkgvacq8dpd8cacbppsds5k2xw7lv"))))
+ "0d66qz9h37pk8h10bc918hbv3j364vyni934rlw2j951s5wznj8n"))))
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases (delete 'configure))
@@ -682,3 +684,66 @@ brightness/contrast/gamma correction, pan with keyboard and mouse, flip,
rotate left/right, jump/forward/backward images, filename filter and use it
to set X desktop background.")
(license license:gpl2)))
+
+(define-public nomacs
+ (package
+ (name "nomacs")
+ (version "3.16.224")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nomacs/nomacs")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05d4hqg0gl3g9s2xf1hr7mc7g4cqarcap4nzxxa51fsphw2b8x16"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:build-type "Release" ; fails to build with debug info
+ #:configure-flags (list "-DENABLE_TRANSLATIONS=true"
+ "-DUSE_SYSTEM_QUAZIP=true"
+ "-DENABLE_OPENCV=true")
+ #:tests? #f ; no rule for target 'test'
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'copy-plugins
+ (lambda* (#:key inputs #:allow-other-keys)
+ (copy-recursively (assoc-ref inputs "plugins")
+ "ImageLounge/plugins")))
+ (add-after 'copy-plugins 'cd-to-source-dir
+ (lambda _ (chdir "ImageLounge") #t)))))
+ (inputs
+ `(("plugins"
+ ,(origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nomacs/nomacs-plugins")
+ (commit "3.16")))
+ (sha256
+ (base32
+ "1cpdwhfvaxm970nwdc1hc13848a85pqqi176m9xpa3krla9qskml"))))
+ ("exiv2" ,exiv2)
+ ("libraw" ,libraw)
+ ("libtiff" ,libtiff)
+ ("opencv" ,opencv)
+ ("python" ,python-wrapper)
+ ("quazip" ,quazip)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("qtlinguist" ,qttools)))
+ (synopsis "Image viewer supporting all common formats")
+ (description "Nomacs is a simple to use image lounge featuring
+semi-transparent widgets that display additional information such as metadata,
+thumbnails and histograms. It is able to browse images compressed archives
+and add notes to images.
+
+Nomacs includes image manipulation methods for adjusting brightness, contrast,
+saturation, hue, gamma, and exposure. It has a pseudo color function which
+allows creating false color images. A unique feature of Nomacs is the
+synchronization of multiple instances.")
+ (home-page "https://nomacs.org/")
+ (license license:gpl3+)))