summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 76f73e03ca..cee7f146fa 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -31,6 +31,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
+ #:use-module (gnu packages graphics)
#:use-module (gnu packages maths)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -132,7 +133,7 @@ Included are a library, libtiff, for reading and writing TIFF and a small
collection of tools for doing simple manipulations of TIFF images.")
(license (license:non-copyleft "file://COPYRIGHT"
"See COPYRIGHT in the distribution."))
- (home-page "http://www.libtiff.org/")))
+ (home-page "http://www.remotesensing.org/libtiff/")))
(define-public libwmf
(package
@@ -508,9 +509,12 @@ graphics image formats like PNG, BMP, JPEG, TIFF and others.")
("fftw" ,fftw)
("fftwf" ,fftwf)
("hdf5" ,hdf5)
+ ("ilmbase" ,ilmbase) ; propagated by openexr, but needed explicitly
+ ; to create a configure-flag
("libjpeg" ,libjpeg)
("libpng" ,libpng)
("libtiff" ,libtiff)
+ ("openexr" ,openexr)
("python" ,python-2) ; print syntax
("python2-numpy" ,python2-numpy)
("zlib" ,zlib)))
@@ -524,7 +528,15 @@ graphics image formats like PNG, BMP, JPEG, TIFF and others.")
(list "-Wno-dev" ; suppress developer mode with lots of warnings
(string-append "-DVIGRANUMPY_INSTALL_DIR="
(assoc-ref %outputs "out")
- "/lib/python2.7/site-packages"))))
+ "/lib/python2.7/site-packages")
+ ;; OpenEXR is not enabled by default.
+ "-DWITH_OPENEXR=1"
+ ;; The header files of ilmbase are not found when included
+ ;; by the header files of openexr, and an explicit flag
+ ;; needs to be set.
+ (string-append "-DCMAKE_CXX_FLAGS=-I"
+ (assoc-ref %build-inputs "ilmbase")
+ "/include/OpenEXR"))))
(synopsis "Computer vision library")
(description
"VIGRA stands for Vision with Generic Algorithms. It is an image