summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm33
1 files changed, 16 insertions, 17 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index d6c39e5c7e..0f15685d33 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2013, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015 Alex Kost <alezost@gmail.com>
-;;; Copyright © 2014, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2014, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Amirouche Boubekki <amirouche@hypermove.net>
;;; Copyright © 2014, 2017 John Darrington <jmd@gnu.org>
@@ -395,7 +395,6 @@ extracting icontainer icon files.")
(package
(name "libtiff")
(version "4.0.9")
- (replacement libtiff/fixed)
(source
(origin
(method url-fetch)
@@ -403,7 +402,9 @@ extracting icontainer icon files.")
version ".tar.gz"))
(sha256
(base32
- "1kfg4q01r4mqn7dj63ifhi6pmqzbf4xax6ni6kkk81ri5kndwyvf"))))
+ "1kfg4q01r4mqn7dj63ifhi6pmqzbf4xax6ni6kkk81ri5kndwyvf"))
+ (patches (search-patches "libtiff-CVE-2017-9935.patch"
+ "libtiff-CVE-2017-18013.patch"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1.3 MiB of HTML documentation
@@ -425,17 +426,6 @@ collection of tools for doing simple manipulations of TIFF images.")
"See COPYRIGHT in the distribution."))
(home-page "http://www.simplesystems.org/libtiff/")))
-(define libtiff/fixed
- (package
- (inherit libtiff)
- (source
- (origin
- (inherit (package-source libtiff))
- (patches
- (append (origin-patches (package-source libtiff))
- (search-patches "libtiff-CVE-2017-9935.patch"
- "libtiff-CVE-2017-18013.patch")))))))
-
(define-public leptonica
(package
(name "leptonica")
@@ -593,7 +583,8 @@ error-resilience, a Java-viewer for j2k-images, ...")
(add-after 'unpack 'disable-html-doc-gen
(lambda _
(substitute* "doc/Makefile.in"
- (("^all: allhtml manpages") ""))))
+ (("^all: allhtml manpages") ""))
+ #t))
(add-after 'install 'install-manpages
(lambda* (#:key outputs #:allow-other-keys)
(let* ((bin (assoc-ref outputs "bin"))
@@ -606,7 +597,8 @@ error-resilience, a Java-viewer for j2k-images, ...")
(copy-file file
(string-append
man1dir "/" base))))
- (find-files "doc" "\\.1"))))))))
+ (find-files "doc" "\\.1"))
+ #t))))))
(synopsis "Tools and library for working with GIF images")
(description
"GIFLIB is a library for reading and writing GIF images. It is API and
@@ -819,7 +811,14 @@ graphics image formats like PNG, BMP, JPEG, TIFF and others.")
("python2-sphinx" ,python2-sphinx)))
(arguments
`(#:test-target "check"
- #:parallel-build? #f ; parallel builds trigger an ICE
+ #:phases
+ (modify-phases %standard-phases
+ ;; See https://github.com/ukoethe/vigra/issues/432
+ (add-after 'unpack 'disable-broken-test
+ (lambda _
+ (substitute* "test/fourier/CMakeLists.txt"
+ (("VIGRA_ADD_TEST.*") ""))
+ #t)))
#:configure-flags
(list "-Wno-dev" ; suppress developer mode with lots of warnings
(string-append "-DVIGRANUMPY_INSTALL_DIR="