summaryrefslogtreecommitdiff
path: root/gnu/packages/instrumentation.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/instrumentation.scm')
-rw-r--r--gnu/packages/instrumentation.scm25
1 files changed, 20 insertions, 5 deletions
diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index 5404f7b714..2ed0b8a283 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -85,7 +85,9 @@
`(#:tests? #f ; FIXME - When Python's bindings are enabled, tests do not
; pass.
#:make-flags
- ,#~(list (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))
+ ,#~(list
+ (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib")
+ "DISTSETUPOPTS=--single-version-externally-managed") ;no .egg files
#:configure-flags
'("--enable-debug-info"
"--enable-man-pages"
@@ -95,11 +97,9 @@
(modify-phases %standard-phases
;; These are recommended in the project's README for a development
;; build configuration.
- (add-before 'configure 'set-environment-variables
+ (add-after 'unpack 'reconfigure
(lambda _
- (setenv "BABELTRACE_DEV_MODE" "1")
- (setenv "BABELTRACE_MINIMAL_LOG_LEVEL" "TRACE")
- (invoke "autoreconf" "-vfi"))))))
+ (delete-file "configure"))))))
(inputs
(list glib))
;; NOTE - elfutils is used for the LTTng debug information filter
@@ -141,6 +141,21 @@ LTTng and barectf. This package provides a library with a C API, Python 3
bindings, and the command-line tool @command{babeltrace2}.")
(license license:expat)))
+(define-public babeltrace/dev
+ (package/inherit babeltrace
+ ;; This dev variant of the package babeltrace is slower but allows better
+ ;; development of plugins as recommended by the authors.
+ (name "babeltrace-dev")
+ (synopsis "Trace manipulation toolkit (variant for plugin developers)")
+ (arguments
+ (substitute-keyword-arguments (package-arguments babeltrace)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-before 'configure 'set-environment-variables
+ (lambda _
+ (setenv "BABELTRACE_DEV_MODE" "1")
+ (setenv "BABELTRACE_MINIMAL_LOG_LEVEL" "TRACE")))))))))
+
(define-public barectf
(package
(name "barectf")