summaryrefslogtreecommitdiff
path: root/gnu/packages/ipfs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ipfs.scm')
-rw-r--r--gnu/packages/ipfs.scm210
1 files changed, 210 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
new file mode 100644
index 0000000000..88afa8e6cb
--- /dev/null
+++ b/gnu/packages/ipfs.scm
@@ -0,0 +1,210 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages ipfs)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ ;; #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system go)
+ ;; #:use-module (guix build-system python)
+ ;; #:use-module (gnu packages)
+ #:use-module (gnu packages golang))
+
+(define-public go-github-com-ipfs-go-ipfs-cmdkit-files
+ (let ((commit
+ "386fcf8f18a185ec121676665fe2d9574496048d")
+ (revision "0"))
+ (package
+ (name "go-github-com-ipfs-go-ipfs-cmdkit-files")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipfs-cmdkit.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qk6fshgdmhp8dip2ksm13j6nywi41m9mn0czkvmw6b697z85l2r"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/ipfs/go-ipfs-cmdkit"
+ #:import-path "github.com/ipfs/go-ipfs-cmdkit/files"))
+ (home-page
+ "https://github.com/ipfs/go-ipfs-cmdkit")
+ (synopsis "Shared types, functions and values for go-ipfs")
+ (description "@command{cmdkit} offers some types, functions and values
+that are shared between @command{go-ipfs/commands} and its rewrite @command{go-ipfs-cmds}.")
+ (license license:expat))))
+
+(define-public go-github-com-ipfs-go-ipfs-api
+ (let ((commit
+ "dafc2a13a4389ac1a6c2786e34ab70a4f26d3a3f")
+ (revision "0"))
+ (package
+ (name "go-github-com-ipfs-go-ipfs-api")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipfs-api.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06kibnwb037sqynk99j07wm8alvxwx3bari9gdax4jv93396kycj"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/ipfs/go-ipfs-api"
+ ;; TODO: Tests fail, might need network access.
+ #:tests? #f))
+ (native-inputs
+ `(("go-github-com-ipfs-go-ipfs-cmdkit-files" ,go-github-com-ipfs-go-ipfs-cmdkit-files)
+ ("go-github-com-libp2p-go-libp2p-metrics" ,go-github-com-libp2p-go-libp2p-metrics)
+ ("go-github-com-libp2p-go-flow-metrics" ,go-github-com-libp2p-go-flow-metrics)
+ ("go-github-com-libp2p-go-libp2p-peer" ,go-github-com-libp2p-go-libp2p-peer)
+ ("go-github-com-libp2p-go-libp2p-protocol" ,go-github-com-libp2p-go-libp2p-protocol)
+ ("go-github-com-libp2p-go-libp2p-crypto" ,go-github-com-libp2p-go-libp2p-crypto)
+ ("go-github-com-mitchellh-go-homedir" ,go-github-com-mitchellh-go-homedir)
+ ("go-github-com-multiformats-go-multiaddr" ,go-github-com-multiformats-go-multiaddr)
+ ("go-github-com-multiformats-go-multiaddr-net" ,go-github-com-multiformats-go-multiaddr-net)
+ ("go-github-com-btcsuite-btcd-btcec" ,go-github-com-btcsuite-btcd-btcec)
+ ("go-github-com-gogo-protobuf-proto" ,go-github-com-gogo-protobuf-proto)
+ ("go-github-com-minio-blake2b-simd" ,go-github-com-minio-blake2b-simd)
+ ("go-github-com-minio-sha256-simd" ,go-github-com-minio-sha256-simd)
+ ("go-github-com-mr-tron-base58" ,go-github-com-mr-tron-base58)
+ ("go-github-com-multiformats-go-multihash" ,go-github-com-multiformats-go-multihash)
+ ("go-golang-org-x-crypto-union" ,(go-golang-org-x-crypto-union))
+ ("go-github-com-spaolacci-murmur3" ,go-github-com-spaolacci-murmur3)
+ ("go-github-com-gxed-hashland-keccakpg" ,go-github-com-gxed-hashland-keccakpg)
+ ("go-github-com-whyrusleeping-tar-utils" ,go-github-com-whyrusleeping-tar-utils)
+ ("go-github-com-cheekybits-is" ,go-github-com-cheekybits-is)))
+ (home-page "https://github.com/ipfs/go-ipfs-api")
+ (synopsis "Unofficial Go interface to IPFS's HTTP API")
+ (description "An unofficial Go interface to IPFS's HTTP API")
+ (license license:expat))))
+
+(define-public gx
+ (let ((commit
+ "89338e509426d2895f20086685cf4c77d64cc5df")
+ (revision "0"))
+ (package
+ (name "gx")
+ (version (git-version "0.14.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/whyrusleeping/gx.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08gh04jln8rxpq0j4fm4chjap162wp8cjwj9szbvj9c7123s42rd"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/whyrusleeping/gx"))
+ (native-inputs
+ `(
+ ("go-github-com-blang-semver" ,go-github-com-blang-semver)
+ ("go-github-com-gxed-hashland-keccakpg" ,go-github-com-gxed-hashland-keccakpg)
+ ("go-github-com-ipfs-go-ipfs-api" ,go-github-com-ipfs-go-ipfs-api)
+ ("go-github-com-ipfs-go-ipfs-cmdkit-files" ,go-github-com-ipfs-go-ipfs-cmdkit-files)
+ ("go-github-com-libp2p-go-flow-metrics" ,go-github-com-libp2p-go-flow-metrics)
+ ("go-github-com-libp2p-go-libp2p-crypto" ,go-github-com-libp2p-go-libp2p-crypto)
+ ("go-github-com-libp2p-go-libp2p-metrics" ,go-github-com-libp2p-go-libp2p-metrics)
+ ("go-github-com-libp2p-go-libp2p-peer" ,go-github-com-libp2p-go-libp2p-peer)
+ ("go-github-com-libp2p-go-libp2p-protocol" ,go-github-com-libp2p-go-libp2p-protocol)
+ ("go-github-com-minio-blake2b-simd" ,go-github-com-minio-blake2b-simd)
+ ("go-github-com-minio-sha256-simd" ,go-github-com-minio-sha256-simd)
+ ("go-github-com-mitchellh-go-homedir" ,go-github-com-mitchellh-go-homedir)
+ ("go-github-com-mr-tron-base58" ,go-github-com-mr-tron-base58)
+ ("go-github-com-multiformats-go-multiaddr" ,go-github-com-multiformats-go-multiaddr)
+ ("go-github-com-multiformats-go-multiaddr-net" ,go-github-com-multiformats-go-multiaddr-net)
+ ("go-github-com-multiformats-go-multihash" ,go-github-com-multiformats-go-multihash)
+ ("go-github-com-spaolacci-murmur3" ,go-github-com-spaolacci-murmur3)
+ ("go-github-com-whyrusleeping-tar-utils" ,go-github-com-whyrusleeping-tar-utils)
+ ("go-golang-org-x-crypto-union" ,(go-golang-org-x-crypto-union))
+ ("go-github-com-btcsuite-btcd-btcec" ,go-github-com-btcsuite-btcd-btcec)
+ ("go-github-com-gogo-protobuf-proto" ,go-github-com-gogo-protobuf-proto)
+ ("go-github-com-sabhiram-go-gitignore" ,go-github-com-sabhiram-go-gitignore)
+ ("go-github-com-urfave-cli" ,go-github-com-urfave-cli)
+ ("go-github-com-whyrusleeping-json-filter" ,go-github-com-whyrusleeping-json-filter)
+ ("go-github-com-whyrusleeping-progmeter" ,go-github-com-whyrusleeping-progmeter)
+ ("go-github-com-whyrusleeping-stump" ,go-github-com-whyrusleeping-stump)))
+ (home-page "https://github.com/whyrusleeping/gx")
+ (synopsis "@command{gx} is a packaging tool built around the
+distributed, content addressed filesystem IPFS. It aims to be flexible,
+powerful and simple.")
+ (description "XXX")
+ (license #f))))
+
+(define-public go-ipfs
+ (let ((commit
+ "9bf4e4145ea897ced2f9aa2087296b3beda6e941")
+ (revision "0"))
+ (package
+ (name "go-ipfs")
+ (version (git-version "0.4.17" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipfs.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01zqll453gbjjfkm6jvpp49i1al8ic3pdg3ivqhyiilcsmhf8b8i"))))
+ (build-system go-build-system)
+ (arguments
+ ;; install_unsupported:
+ ;; @echo "note: this command has yet to be tested to build in the system you are using"
+ ;; @echo "installing gx"
+ ;; go get -v -u github.com/whyrusleeping/gx
+ ;; go get -v -u github.com/whyrusleeping/gx-go
+ ;; @echo check gx and gx-go
+ ;; gx -v && gx-go -v
+ ;; @echo downloading dependencies
+ ;; gx install --global
+ ;; @echo "installing go-ipfs"
+ ;; go install -v -tags nofuse ./cmd/ipfs
+ '(#:import-path "github.com/ipfs/go-ipfs/cmd/ipfs"
+ #:unpack-path "github.com/ipfs/go-ipfs"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (map (lambda (file)
+ (make-file-writable file))
+ (find-files
+ (assoc-ref outputs "out")
+ ".*\\.gz$"))
+ #t)))))
+ (native-inputs `())
+ (home-page "https://ipfs.io")
+ (synopsis "IPFS implementation in Go ")
+ (description "IPFS is a global, versioned, peer-to-peer filesystem. It
+combines good ideas from Git, BitTorrent, Kademlia, SFS, and the Web. It is
+like a single bittorrent swarm, exchanging git objects. IPFS provides an
+interface as simple as the HTTP web, but with permanence built in. You can
+also mount the world at /ipfs.")
+ (license license:expat))))