summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm42
1 files changed, 38 insertions, 4 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index ce6bc4fe9d..8b3b172ae9 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -8081,12 +8081,14 @@ more efficient storage-wise than an uncompressed bitmap (as implemented in the
(name "java-slf4j-api")
(version "1.7.25")
(source (origin
- (method url-fetch)
- (uri (string-append "https://www.slf4j.org/dist/slf4j-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/qos-ch/slf4j")
+ (commit (string-append "v_" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "13j51sgzmhhdrfa74gkal5zpip7r1440dh7zsi2c8bpb2zs1v8kb"))
+ "15n42zq3k1iyn752nwdcbs44hxns2rmxhglwjfr4np7lxx56apjl"))
(modules '((guix build utils)))
;; Delete bundled jars.
(snippet
@@ -8182,6 +8184,38 @@ all events to System.err. Only messages of level INFO and higher are
printed.")
(license license:expat)))
+(define-public java-slf4j-nop
+ (package
+ (name "java-slf4j-nop")
+ (version "1.7.25")
+ (source (package-source java-slf4j-api))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "slf4j-nop.jar"
+ #:source-dir "slf4j-nop/src/main"
+ #:test-dir "slf4j-nop/src/test"
+ #:phases (modify-phases %standard-phases
+ ;; The tests need some test classes from slf4j-api
+ (add-before 'check 'build-slf4j-api-test-helpers
+ (lambda _
+ ;; Add current dir to CLASSPATH ...
+ (setenv "CLASSPATH"
+ (string-append (getcwd) ":"
+ (getenv "CLASSPATH")))
+ ;; ... and build test helper classes here:
+ (apply invoke
+ `("javac" "-d" "."
+ ,@(find-files "slf4j-api/src/test" ".*\\.java")))))
+ (replace 'install
+ (install-from-pom "slf4j-nop/pom.xml")))))
+ (propagated-inputs (list java-slf4j-api))
+ (native-inputs (list java-junit java-hamcrest-core))
+ (home-page "https://www.slf4j.org/")
+ (synopsis "SLF4J binding that silently discards all logging messages")
+ (description "Binding/provider for NOP, an implementation that silently
+discards all logging messages.")
+ (license license:expat)))
+
(define-public antlr2
(package
(name "antlr2")