summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm31
1 files changed, 20 insertions, 11 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 1efa657816..829cbf9c5f 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -61,6 +61,7 @@
#:use-module (gnu packages libffi)
#:use-module (gnu packages linux) ;alsa
#:use-module (gnu packages maths)
+ #:use-module (gnu packages onc-rpc)
#:use-module (gnu packages web)
#:use-module (gnu packages wget)
#:use-module (gnu packages pkg-config)
@@ -551,9 +552,10 @@ machine.")))
"--disable-gjdoc")
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
- (lambda _
- (zero? (system* "autoreconf" "-vif"))))
+ ;; XXX The bootstrap phase executes autogen.sh, which fails after
+ ;; complaining about the lack of gettext.
+ (replace 'bootstrap
+ (lambda _ (invoke "autoreconf" "-vif")))
(add-after 'unpack 'remove-unsupported-annotations
(lambda _
(substitute* (find-files "java" "\\.java$")
@@ -622,10 +624,12 @@ machine.")))
"0bg9sb4f7qbq77c0zf9m17p47ga0kf0r9622g9p12ysg26jd1ksg"))
(modules '((guix build utils)))
(snippet
- '(substitute* "Makefile.in"
- ;; do not leak information about the build host
- (("DISTRIBUTION_ID=\"\\$\\(DIST_ID\\)\"")
- "DISTRIBUTION_ID=\"\\\"guix\\\"\"")))))
+ '(begin
+ (substitute* "Makefile.in"
+ ;; do not leak information about the build host
+ (("DISTRIBUTION_ID=\"\\$\\(DIST_ID\\)\"")
+ "DISTRIBUTION_ID=\"\\\"guix\\\"\""))
+ #t))))
(build-system gnu-build-system)
(outputs '("out" ; Java Runtime Environment
"jdk" ; Java Development Kit
@@ -845,6 +849,7 @@ machine.")))
("fastjar" ,fastjar)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
+ ("gcc" ,gcc-4.9) ; there's a segmentation fault when compiling with gcc-5 or gcc-7
("gtk" ,gtk+-2)
("gawk" ,gawk)
("giflib" ,giflib)
@@ -852,6 +857,7 @@ machine.")))
("jamvm" ,jamvm)
("lcms" ,lcms)
("libjpeg" ,libjpeg)
+ ("libnsl" ,libnsl)
("libpng" ,libpng)
("libtool" ,libtool)
("libx11" ,libx11)
@@ -968,10 +974,12 @@ bootstrapping purposes.")
"1w331rdqx1dcx2xb0fmjmrkdc71xqn20fxsgw8by4xhiblh88khh"))
(modules '((guix build utils)))
(snippet
- '(substitute* "Makefile.in"
- ;; do not leak information about the build host
- (("DISTRIBUTION_ID=\"\\$\\(DIST_ID\\)\"")
- "DISTRIBUTION_ID=\"\\\"guix\\\"\"")))))
+ '(begin
+ (substitute* "Makefile.in"
+ ;; do not leak information about the build host
+ (("DISTRIBUTION_ID=\"\\$\\(DIST_ID\\)\"")
+ "DISTRIBUTION_ID=\"\\\"guix\\\"\""))
+ #t))))
(build-system gnu-build-system)
(outputs '("out" ; Java Runtime Environment
"jdk" ; Java Development Kit
@@ -1399,6 +1407,7 @@ bootstrapping purposes.")
("coreutils" ,coreutils)
("diffutils" ,diffutils) ;for tests
("gawk" ,gawk)
+ ("gcc" ,gcc-4.9) ; there's a segmentation fault when compiling with gcc-5
("grep" ,grep)
("libtool" ,libtool)
("pkg-config" ,pkg-config)