summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm32
1 files changed, 19 insertions, 13 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index e2a0f75f76..2724f0f20a 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -7,6 +7,8 @@
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2018 Chris Marusich <cmmarusich@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2018,25 +2020,20 @@ debugging, etc.")
(define-public java-classpathx-servletapi
(package
(name "java-classpathx-servletapi")
- (version "3.0")
+ (version "3.0.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/classpathx/servletapi/"
"servletapi-" version ".tar.gz"))
(sha256
(base32
- "0y9489pk4as9q6x300sk3ycc0psqfxcd4b0xvbmf3rhgli8q1kx3"))))
+ "07d8h051siga2f33fra72hk12sbq1bxa4jifjg0qj0vfazjjff0x"))))
(build-system ant-build-system)
(arguments
`(#:tests? #f ; there is no test target
#:build-target "compile"
- ;; NOTE: This package does not build with Java 8 because of a type
- ;; mismatch in
- ;; "source/javax/servlet/jsp/el/ImplicitObjectELResolver.java". It
- ;; defines the return value of ScopeMap's "remove" method to be of type
- ;; "Object", whereas Map's "remove" method returns boolean.
#:make-flags
- (list "-Dbuild.compiler=javac1.7"
+ (list "-Dbuild.compiler=javac1.8"
(string-append "-Ddist=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
@@ -2665,23 +2662,31 @@ archives (jar).")
(define-public java-asm
(package
(name "java-asm")
- (version "5.2")
+ (version "6.0")
(source (origin
(method url-fetch)
(uri (string-append "http://download.forge.ow2.org/asm/"
"asm-" version ".tar.gz"))
(sha256
(base32
- "0kxvmv5275rnjl7jv0442k3wjnq03ngkb7sghs78avf45pzm4qgr"))))
+ "115l5pqblirdkmzi32dxx7gbcm4jy0s14y5wircr6h8jdr9aix00"))))
(build-system ant-build-system)
+ (propagated-inputs
+ `(("java-aqute-bndlib" ,java-aqute-bndlib)))
(arguments
`(#:build-target "compile"
;; The tests require an old version of Janino, which no longer compiles
;; with the JDK7.
#:tests? #f
- ;; We don't need these extra ant tasks, but the build system asks us to
- ;; provide a path anyway.
- #:make-flags (list (string-append "-Dobjectweb.ant.tasks.path=foo"))
+ #:make-flags
+ (list
+ ;; We don't need these extra ant tasks, but the build system asks us to
+ ;; provide a path anyway.
+ "-Dobjectweb.ant.tasks.path=dummy-path"
+ ;; The java-aqute.bndlib JAR file will be put onto the classpath and
+ ;; used during the build automatically by ant-build-system, but
+ ;; java-asm's build.xml fails unless we provide something here.
+ "-Dbiz.aQute.bnd.path=dummy-path")
#:phases
(modify-phases %standard-phases
(add-before 'install 'build-jars
@@ -3272,6 +3277,7 @@ file filters and endian classes.")
(outputs '("out" "doc"))
(arguments
`(#:test-target "test"
+ #:test-exclude (list "**/Abstract*.java" "**/Random*.java")
#:phases
(modify-phases %standard-phases
(add-after 'build 'build-javadoc ant-build-javadoc)