summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index e2a0f75f76..d8c2c325bc 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2018,25 +2018,20 @@ debugging, etc.")
(define-public java-classpathx-servletapi
(package
(name "java-classpathx-servletapi")
- (version "3.0")
+ (version "3.0.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/classpathx/servletapi/"
"servletapi-" version ".tar.gz"))
(sha256
(base32
- "0y9489pk4as9q6x300sk3ycc0psqfxcd4b0xvbmf3rhgli8q1kx3"))))
+ "07d8h051siga2f33fra72hk12sbq1bxa4jifjg0qj0vfazjjff0x"))))
(build-system ant-build-system)
(arguments
`(#:tests? #f ; there is no test target
#:build-target "compile"
- ;; NOTE: This package does not build with Java 8 because of a type
- ;; mismatch in
- ;; "source/javax/servlet/jsp/el/ImplicitObjectELResolver.java". It
- ;; defines the return value of ScopeMap's "remove" method to be of type
- ;; "Object", whereas Map's "remove" method returns boolean.
#:make-flags
- (list "-Dbuild.compiler=javac1.7"
+ (list "-Dbuild.compiler=javac1.8"
(string-append "-Ddist=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
@@ -3272,6 +3267,7 @@ file filters and endian classes.")
(outputs '("out" "doc"))
(arguments
`(#:test-target "test"
+ #:test-exclude (list "**/Abstract*.java" "**/Random*.java")
#:phases
(modify-phases %standard-phases
(add-after 'build 'build-javadoc ant-build-javadoc)