summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm62
1 files changed, 44 insertions, 18 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 64e41b510d..95c0f95e8c 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -103,7 +103,7 @@
(define-public extra-cmake-modules
(package
(name "extra-cmake-modules")
- (version "5.114.0")
+ (version "6.0.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -112,7 +112,7 @@
name "-" version ".tar.xz"))
(sha256
(base32
- "0z4nqravsfzlsgvkg5rha2d0qxfr3pfncw7z2fxzzqvzj7mfk6im"))))
+ "030dyw4krnq8hcp0dsqb15zxb7x7r8c33lbdgmmia5xpkpqjp693"))))
(build-system cmake-build-system)
(native-inputs
;; Add test dependency, except on armhf where building it is too
@@ -509,6 +509,12 @@ GZip format, via a subclass of QIODevice.")
(list
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-test
+ (lambda _
+ ;; Reported as https://bugs.kde.org/show_bug.cgi?id=484306
+ (substitute* "autotests/CMakeLists.txt"
+ (("testdateserialization")
+ ""))))
(add-before 'check 'check-setup
(lambda* (#:key inputs #:allow-other-keys) ;;; XXX: failing test
(setenv "QT_QPA_PLATFORM" "offscreen")
@@ -563,7 +569,7 @@ Internet).")
(define-public kcolorpicker
(package
(name "kcolorpicker")
- (version "0.3.0")
+ (version "0.3.1")
(source
(origin
(method git-fetch)
@@ -573,7 +579,7 @@ Internet).")
(file-name (git-file-name name version))
(sha256
(base32
- "1zg078mkdapsd6vq7qy2vxbfzn6i382ss1a1w0xzvpy148ifaj42"))))
+ "1px40rasvz0r5db9av125q9mlyjz4xdnckg2767i3fndj3ic0vql"))))
(build-system qt-build-system)
(propagated-inputs (list qtbase-5))
(arguments
@@ -1154,9 +1160,17 @@ protocols used in KDE Plasma.")
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "ctest" "-E"
- ;; XXX: maybe is upstream bug
- "(kwayland-testWaylandRegistry|\
-kwayland-testPlasmaShell|kwayland-testPlasmaWindowModel)")))))))
+ (string-append
+ "("
+ (string-join
+ ;; XXX: maybe is upstream bug
+ '("kwayland-testWaylandRegistry"
+ "kwayland-testPlasmaShell"
+ "kwayland-testPlasmaWindowModel"
+ ;; The 'kwayland-testXdgForeign' may fail on
+ ;; powerpc64le with a 'Subprocess aborted' error.
+ "kwayland-testXdgForeign") "|")
+ ")"))))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Qt-style API to interact with the wayland client and server")
(description "As the names suggest they implement a Client respectively a
@@ -1847,7 +1861,7 @@ by applications to write metadata.")
(define-public kimageannotator
(package
(name "kimageannotator")
- (version "0.7.0")
+ (version "0.7.1")
(source
(origin
(method git-fetch)
@@ -1857,10 +1871,11 @@ by applications to write metadata.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ac0cxbq88zzvkgs5d39xpzk0h7xhl57yswgd760x77py0rl5bqf"))))
+ "1f1y4r5rb971v2g34fgjbr14g0mdms5h66yl5k0p1zf50kr2wnic"))))
(build-system qt-build-system)
(arguments
- (list #:configure-flags #~'("-DBUILD_TESTS=ON")
+ (list #:configure-flags #~'("-DBUILD_SHARED_LIBS=ON"
+ "-DBUILD_TESTS=ON")
#:phases
#~(modify-phases %standard-phases
(replace 'check
@@ -1874,8 +1889,6 @@ by applications to write metadata.")
(list qttools-5 xorg-server-for-tests))
(inputs
(list googletest qtsvg-5 kcolorpicker))
- (propagated-inputs
- (list qtbase-5))
(home-page "https://github.com/ksnip/kImageAnnotator")
(synopsis "Image annotating library")
(description "This library provides tools to annotate images.")
@@ -1985,7 +1998,7 @@ asynchronous jobs.")
phonon
qtdeclarative-5
qtbase-5
- qtspeech
+ qtspeech-5
qtx11extras))
(arguments
(list #:phases #~(modify-phases %standard-phases
@@ -2027,9 +2040,6 @@ covers feedback and persistent events.")
qtbase-5))
(arguments
(list
- ;; The `plasma-querytest' test is known to fail when tests are run in parallel:
- ;; <https://sources.debian.org/src/kpackage/5.107.0-1/debian/changelog/#L92>
- #:parallel-tests? #f
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch
@@ -2056,6 +2066,13 @@ covers feedback and persistent events.")
"filePath(\"etc\", QStringLiteral(\"passwd\"))")
(("\"/bin/ls\"")
"\"/etc/passwd\""))))
+ (add-after 'unpack 'disable-problematic-tests
+ (lambda _
+ ;; The 'plasma-query' test fails non-deterministically, as
+ ;; reported e.g. in <https://bugs.gentoo.org/919151>.
+ (substitute* "autotests/CMakeLists.txt"
+ ((".*querytest.*")
+ ""))))
(add-before 'check 'check-setup
(lambda _
(setenv "HOME" (getcwd)))))))
@@ -3249,7 +3266,7 @@ library.")
kwidgetsaddons
kwindowsystem
qtbase-5
- qtspeech))
+ qtspeech-5))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Text editing widgets")
(description "KTextWidgets provides widgets for displaying and editing text.
@@ -3653,7 +3670,16 @@ workspace.")
(version-major+minor version) "/portingAids/"
name "-" version ".tar.xz"))
(sha256
- (base32 "17473him2fjfcw5f88diarqac815wsakfyb9fka82a4qqh9l41mc"))))
+ (base32 "17473him2fjfcw5f88diarqac815wsakfyb9fka82a4qqh9l41mc"))
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* "autotests/kmimetypetest.cpp"
+ ;; Adjust the test for shared-mime-info changes:
+ ;; https://gitlab.freedesktop.org/xdg/shared-mime-info/-/issues/202
+ ;; https://gitlab.freedesktop.org/xdg/shared-mime-info/-/merge_requests/255
+ (("empty document") "Empty document")
+ (("Bzip archive") "Bzip2 archive")
+ (("<< \"application/x-bzip") "<< \"application/x-bzip2")))))
(build-system cmake-build-system)
(native-inputs
(list dbus