summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index f487ac9a30..8991c36f89 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1645,9 +1645,9 @@ with other frameworks.")
(("@KAUTH_POLICY_FILES_INSTALL_DIR@")
"${KDE_INSTALL_DATADIR}/polkit-1/actions")
(("@KAUTH_HELPER_INSTALL_DIR@")
- "${KDE_INSTALL_LIBEXECDIR}")
+ "${KDE_INSTALL_LIBEXECDIR}/kauth")
(("@KAUTH_HELPER_INSTALL_ABSOLUTE_DIR@")
- "${KDE_INSTALL_LIBEXECDIR}"))))
+ "${KDE_INSTALL_FULL_LIBEXECDIR}/kauth"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
@@ -3670,7 +3670,16 @@ workspace.")
(version-major+minor version) "/portingAids/"
name "-" version ".tar.xz"))
(sha256
- (base32 "17473him2fjfcw5f88diarqac815wsakfyb9fka82a4qqh9l41mc"))))
+ (base32 "17473him2fjfcw5f88diarqac815wsakfyb9fka82a4qqh9l41mc"))
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* "autotests/kmimetypetest.cpp"
+ ;; Adjust the test for shared-mime-info changes:
+ ;; https://gitlab.freedesktop.org/xdg/shared-mime-info/-/issues/202
+ ;; https://gitlab.freedesktop.org/xdg/shared-mime-info/-/merge_requests/255
+ (("empty document") "Empty document")
+ (("Bzip archive") "Bzip2 archive")
+ (("<< \"application/x-bzip") "<< \"application/x-bzip2")))))
(build-system cmake-build-system)
(native-inputs
(list dbus