summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm92
1 files changed, 46 insertions, 46 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index fff98bd16d..353f9e4528 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016,2017,2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2016-2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -56,12 +56,14 @@
#:use-module (gnu packages libreoffice)
#:use-module (gnu packages linux)
#:use-module (gnu packages mp3)
+ #:use-module (gnu packages openbox)
#:use-module (gnu packages pdf)
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages polkit)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
@@ -566,9 +568,16 @@ propagate their changes to their respective configuration files.")
(inputs
`(("qtbase" ,qtbase)))
(arguments
- `(#:tests? #f ; FIXME: Test failure caused by stout/stderr being interleaved.
- #:phases
+ `(#:phases
(modify-phases %standard-phases
+ (add-before 'check 'blacklist-failing-test
+ (lambda _
+ ;; Blacklist a failing test-function. FIXME: Make it pass.
+ ;; Test failure caused by stout/stderr being interleaved.
+ (with-output-to-file "autotests/BLACKLIST"
+ (lambda _
+ (display "[test_channels]\n*\n")))
+ #t))
(add-before 'check 'check-setup
(lambda _
(setenv "HOME" (getcwd))
@@ -797,19 +806,6 @@ or user activity.")
("qtsvg" ,qtsvg)
;; Run-time dependency
("qtgraphicaleffects" ,qtgraphicaleffects)))
- (arguments
- `(#:tests? #f ;; FIXME: Test suite is broken,
- ;; see https://bugs.kde.org/show_bug.cgi?id=386456
- ;; Note for when enabling the tests: The test-suite is meant to be run
- ;; without prior installation, see
- ;; https://cgit.kde.org/kirigami.git/commit/?id=24ad2c9
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda* (#:key outputs #:allow-other-keys)
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "QtQuick components for mobile user interfaces")
(description "Kirigami is a set of high level QtQuick components looking
@@ -1099,6 +1095,7 @@ configuration pages, message boxes, and password requests.")
`(("extra-cmake-modules" ,extra-cmake-modules)
("pkg-config" ,pkg-config)
("dbus" ,dbus) ; for the tests
+ ("openbox" ,openbox) ; for the tests
("qttools" ,qttools)
("xorg-server" ,xorg-server))) ; for the tests
(inputs
@@ -1107,31 +1104,26 @@ configuration pages, message boxes, and password requests.")
("qtx11extras" ,qtx11extras)
("xcb-utils-keysyms" ,xcb-util-keysyms)))
(arguments
- `(#:tests? #f ; FIXME: 3/12 tests fail.
- #:phases
+ `(#:phases
(modify-phases %standard-phases
- (delete 'check)
- (add-after 'install 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- ;; TODO: Simplify and use "common" phases when test-suite passes
- (if tests?
- (begin
- (let ((out (assoc-ref outputs "out")))
- (setenv "QT_PLUGIN_PATH"
- (string-append out "/lib/qt5/plugins:"
- (getenv "QT_PLUGIN_PATH"))))
- ;; The test suite requires a running X server, setting
- ;; QT_QPA_PLATFORM=offscreen does not suffice and even make
- ;; some tests fail.
- (system (string-append (assoc-ref inputs "xorg-server")
- "/bin/Xvfb :1 -screen 0 640x480x24 &"))
- (setenv "DISPLAY" ":1")
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
- (setenv "DBUS_FATAL_WARNINGS" "0")
- (zero? (system* "dbus-launch" "ctest" ".")))
- (begin
- (format #t "test suite not run~%")
- #t)))))))
+ (add-before 'check 'blacklist-failing-tests
+ (lambda _
+ ;; Blacklist a failing test-functions. FIXME: Make it pass.
+ (with-output-to-file "autotests/BLACKLIST"
+ (lambda _
+ (display "[testState]\n*\n")
+ (display "[testSupported]\n*\n")))
+ #t))
+ (replace 'check
+ (lambda _
+ ;; The test suite requires a running window anager
+ (system "Xvfb :1 -ac -screen 0 640x480x24 &")
+ (setenv "DISPLAY" ":1")
+ (sleep 5) ;; Give Xvfb a few moments to get on it's feet
+ (system "openbox &")
+ (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (invoke "dbus-launch" "ctest" "."))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "KDE access to the windowing system")
(description "KWindowSystem provides information about and allows
@@ -1840,8 +1832,7 @@ covers feedback and persistent events.")
("ki18n" ,ki18n)
("qtbase" ,qtbase)))
(arguments
- `(#:tests? #f ; FIXME: 3/9 tests fail.
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch
(lambda _
@@ -1853,6 +1844,17 @@ covers feedback and persistent events.")
(("^\\s*(QDirIterator it\\(.*, QDirIterator::Subdirectories)(\\);)" _ a b)
(string-append a " | QDirIterator::FollowSymlinks" b)))
#t))
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ ;; /bin/ls doesn't exist in the build-container use /etc/passwd
+ (substitute* "autotests/packagestructuretest.cpp"
+ (("(addDirectoryDefinition\\(\")bin(\".*\")bin(\".*\")bin\""
+ _ a b c)
+ (string-append a "etc" b "etc" c "etc\""))
+ (("filePath\\(\"bin\", QStringLiteral\\(\"ls\"))")
+ "filePath(\"etc\", QStringLiteral(\"passwd\"))")
+ (("\"/bin/ls\"") "\"/etc/passwd\""))
+ #t))
(add-before 'check 'check-setup
(lambda _
(setenv "HOME" (getcwd))
@@ -2419,8 +2421,7 @@ engine WebKit via QtWebKit.")
("kcoreaddons" ,kcoreaddons)
("qtbase" ,qtbase)))
(arguments
- `(#:tests? #f ; FIXME: 2/2 tests fail.
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-before 'check 'check-setup
(lambda _
@@ -2728,8 +2729,7 @@ KIO enabled infrastructure.")
("solid" ,solid)
("sonnet" ,sonnet)))
(arguments
- `(#:tests? #f ; FIXME: 1/3 tests fail.
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-before 'check 'check-setup
(lambda _ ; XDG_DATA_DIRS isn't set