summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 76836d718b..714072e84b 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -713,19 +713,19 @@ text documents, vector drawings, presentations and spreadsheets.")
(define-public libmwaw
(package
(name "libmwaw")
- (version "0.3.16")
+ (version "0.3.17")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/libmwaw/libmwaw/libmwaw-"
version "/libmwaw-" version ".tar.xz"))
(sha256
- (base32 "0s0qvrmxzs8wv4304p7zx9mrasglyaszafqrfmaxwyr9lpdrwqqc"))))
+ (base32 "074ipcq9w7jbd5x316dzclddgia2ydw098ph9d7p3d713pmkf5cf"))))
(build-system gnu-build-system)
(native-inputs
`(("doxygen" ,doxygen)
("pkg-config" ,pkg-config)))
- (propagated-inputs ; in Requires field of .pkg
+ (propagated-inputs ; in Requires field of .pc file
`(("librevenge" ,librevenge)))
(inputs
`(("boost" ,boost)
@@ -1102,7 +1102,8 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
("flex" ,flex)
("pkg-config" ,pkg-config)
("python" ,python-wrapper)
- ("which" ,which)))
+ ("which" ,which)
+ ("ziptime" ,ziptime)))
(inputs
`(("bluez" ,bluez)
("boost" ,boost)
@@ -1216,6 +1217,13 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
"/bin/xdg-open")))
#t))
+ (add-after 'install 'reset-zip-timestamps
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (for-each (lambda (file)
+ (invoke "ziptime" file))
+ ;; So many different extensions for .zip files.
+ (find-files out "\\.(bau|dat|otp|ott|zip)$")))))
(add-after 'install 'bin-and-desktop-install
;; Create 'soffice' and 'libreoffice' symlinks to the executable
;; script.