summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm138
1 files changed, 55 insertions, 83 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8de354732a..f81a403eda 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012-2021, 2021-2023 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2021, 2021-2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Mark H Weaver <mhw@netris.org>
@@ -500,78 +500,60 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
"linux-" version ".tar.xz"))
(sha256 hash)))
-;; The current "mainline" kernel.
-(define-public linux-libre-6.8-version "6.8.6")
+;; The current "stable" kernels. That is, the most recently released major
+;; versions that are still supported upstream.
+
+(define-public linux-libre-6.8-version "6.8.10")
(define-public linux-libre-6.8-gnu-revision "gnu")
(define deblob-scripts-6.8
(linux-libre-deblob-scripts
linux-libre-6.8-version
linux-libre-6.8-gnu-revision
- (base32 "1kqwcm8baq3zx1z8jrgnvm9yps3y9jbf4pv1pbqqprpdscgl9089")
- (base32 "1x7lmy8lff4g4hm67c97797ws594xv5c6l2v5mahj4xh4pb3b8d6")))
+ (base32 "0340z315zxz8wd2vlw5i5hgha10iy2yql1bglgl3dci7d2mvmihn")
+ (base32 "1lr4jgj7ii06fgkhnygvkvhz1sp898z801f7sc3zl70241ld06lb")))
(define-public linux-libre-6.8-pristine-source
(let ((version linux-libre-6.8-version)
- (hash (base32 "158rb8x4qaig8ywbr6n2jnqpl9wgqha4ghs3y3mlbaq3sqr34wly")))
+ (hash (base32 "0xjirg2w5fc2w2q6wr702akszq32m31lk4q5nbjq10zqhbcr5fxh")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-6.8)))
-
-
-;; The current "stable" kernels. That is, the most recently released major
-;; versions that are still supported upstream.
-
-(define-public linux-libre-6.7-version "6.7.12")
-(define-public linux-libre-6.7-gnu-revision "gnu")
-(define deblob-scripts-6.7
- (linux-libre-deblob-scripts
- linux-libre-6.7-version
- linux-libre-6.7-gnu-revision
- (base32 "1ddngihfmwffgvxxv8xsppi76r6grvdxr6zzfzvgl9qw07a6c9fd")
- (base32 "16zh4cj1q7khl943ij4fzc815plbcdllns93chv6725gsm338hsl")))
-(define-public linux-libre-6.7-pristine-source
- (let ((version linux-libre-6.7-version)
- (hash (base32 "113rf3jqfpf3wcv637zbq5ww2hpaaf23y6dsmkds01l8jkipjabc")))
- (make-linux-libre-source version
- (%upstream-linux-source version hash)
- deblob-scripts-6.7)))
-
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
-(define-public linux-libre-6.6-version "6.6.27")
+(define-public linux-libre-6.6-version "6.6.31")
(define-public linux-libre-6.6-gnu-revision "gnu")
(define deblob-scripts-6.6
(linux-libre-deblob-scripts
linux-libre-6.6-version
linux-libre-6.6-gnu-revision
- (base32 "1qm8f3fq4yx59f7b6yky5ryyf229ypxnry922sr8cy0s7mp62cmv")
- (base32 "0s8ys7nz4p50c766f3z9h68vxnrsrgps1i5zskk3cjwik3q60an8")))
+ (base32 "1a28pdl645bj4d8gac71dmwmll6a2kgd3k7gkpfvi94yqkzd9r2z")
+ (base32 "115kma7n9c1z9iqp8xnm4mvfz8cgqmc6jn6a7jg5vq0d4c7nr92w")))
(define-public linux-libre-6.6-pristine-source
(let ((version linux-libre-6.6-version)
- (hash (base32 "14c229mcrd2rd2vjp0c3apzqifn6mkz0rcbw07nj73rw1q3517k3")))
+ (hash (base32 "080wwrc231fbf43hvvygddmdxdspyw23jc5vnd6fr5ccdybgzv6n")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-6.6)))
-(define-public linux-libre-6.1-version "6.1.86")
+(define-public linux-libre-6.1-version "6.1.91")
(define-public linux-libre-6.1-gnu-revision "gnu")
(define deblob-scripts-6.1
(linux-libre-deblob-scripts
linux-libre-6.1-version
linux-libre-6.1-gnu-revision
(base32 "1sf80f2i4vf888xjcn84ymn4w5ynn30ib9033zwmv7f09yvfhapy")
- (base32 "0104m61mqhlmsjjprj51njwbffjcqgjln5bf1wknb6y3iiazl6ng")))
+ (base32 "0nq8b6rnn031wl0qz7ahyfs3hcb0qsr7hzdmxi2g33ycsm9955lk")))
(define-public linux-libre-6.1-pristine-source
(let ((version linux-libre-6.1-version)
- (hash (base32 "0nqiwcaln36drkcaav96dymd2y8rv7wj6a5xjl58f2hg9z2cilyk")))
+ (hash (base32 "1v2d5syxwwqlhvjzxk003qz9sr18r0n8dgg976vbi492r9iww2l8")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-6.1)))
-(define-public linux-libre-5.15-version "5.15.155")
+(define-public linux-libre-5.15-version "5.15.159")
(define-public linux-libre-5.15-gnu-revision "gnu")
(define deblob-scripts-5.15
(linux-libre-deblob-scripts
@@ -581,12 +563,12 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "121shkzgixmywa19xx5f2yxg1primarpg4bxin3jyw0214xbfh2n")))
(define-public linux-libre-5.15-pristine-source
(let ((version linux-libre-5.15-version)
- (hash (base32 "1r16j5asd8v5hr5b0sb8z2wmp6say928pgm13k4iyv9fdnw5jn68")))
+ (hash (base32 "1ia1nfci2wkx4nhnldfczpcq47mp7y7g657ikkh8i72y498gwy1l")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.15)))
-(define-public linux-libre-5.10-version "5.10.215")
+(define-public linux-libre-5.10-version "5.10.217")
(define-public linux-libre-5.10-gnu-revision "gnu1")
(define deblob-scripts-5.10
(linux-libre-deblob-scripts
@@ -596,12 +578,12 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "12csh2zyjrqzgqcv799gv8h4xaw1irxh2zqddn4jqp5p7psx4j5k")))
(define-public linux-libre-5.10-pristine-source
(let ((version linux-libre-5.10-version)
- (hash (base32 "1af6h86flx96pszg006agpak2f9dkk2jqaazfykd7aafqdcs3747")))
+ (hash (base32 "0qhzqrjci45vcbzjch7vq75i6hpyap6yb7jw6g71phcnqgzw2ay5")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.10)))
-(define-public linux-libre-5.4-version "5.4.274")
+(define-public linux-libre-5.4-version "5.4.276")
(define-public linux-libre-5.4-gnu-revision "gnu1")
(define deblob-scripts-5.4
(linux-libre-deblob-scripts
@@ -611,12 +593,12 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "0x0xg0fcykpd117x3q0gim8jilhx922ashhckjvafxv2gk2zzjhj")))
(define-public linux-libre-5.4-pristine-source
(let ((version linux-libre-5.4-version)
- (hash (base32 "1m4yyyv48mfkzhqms88dv1jf39zsfp88az5zpqynmm1wlhhv9iza")))
+ (hash (base32 "01vfx19n8rv9fgjjzvi78125md71zgn5jrinbarabzr18jyjwwg2")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.4)))
-(define-public linux-libre-4.19-version "4.19.312")
+(define-public linux-libre-4.19-version "4.19.314")
(define-public linux-libre-4.19-gnu-revision "gnu1")
(define deblob-scripts-4.19
(linux-libre-deblob-scripts
@@ -626,7 +608,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "0fgkp3v7qgqpn7l1987xcwwlrmwsbscqnxfv06p8nkavrhymrv3c")))
(define-public linux-libre-4.19-pristine-source
(let ((version linux-libre-4.19-version)
- (hash (base32 "0jppa4p73pssd7m3jpc7i6rgnj9gawjcgk4wmqyy87ijzrgzm553")))
+ (hash (base32 "0nvrpg5aj2q4h2drmczprqaprcc2zhcrijfri77b830ms8rg4y2a")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-4.19)))
@@ -664,11 +646,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(list %boot-logo-patch
%linux-libre-arm-export-__sync_icache_dcache-patch)))
-(define-public linux-libre-6.7-source
- (source-with-patches linux-libre-6.7-pristine-source
- (list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch)))
-
(define-public linux-libre-6.6-source
(source-with-patches linux-libre-6.6-pristine-source
(list %boot-logo-patch
@@ -789,11 +766,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
linux-libre-6.8-gnu-revision
linux-libre-6.8-source))
-(define-public linux-libre-headers-6.7
- (make-linux-libre-headers* linux-libre-6.7-version
- linux-libre-6.7-gnu-revision
- linux-libre-6.7-source))
-
(define-public linux-libre-headers-6.6
(make-linux-libre-headers* linux-libre-6.6-version
linux-libre-6.6-gnu-revision
@@ -1133,14 +1105,6 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
-(define-public linux-libre-6.7
- (make-linux-libre* linux-libre-6.7-version
- linux-libre-6.7-gnu-revision
- linux-libre-6.7-source
- '("x86_64-linux" "i686-linux" "armhf-linux"
- "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
- #:configuration-file kernel-config))
-
(define-public linux-libre-6.8
(make-linux-libre* linux-libre-6.8-version
linux-libre-6.8-gnu-revision
@@ -1601,7 +1565,7 @@ is also needed for the @code{tuxedo-control-center} (short tcc) package.")
(define-public evdi
(package
(name "evdi")
- (version "1.14.1") ;inherited by libevdi
+ (version "1.14.4") ;inherited by libevdi
(source
(origin
(method git-fetch)
@@ -1610,7 +1574,7 @@ is also needed for the @code{tuxedo-control-center} (short tcc) package.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0vfbph6bdb206zgdp0bvpqck2zvkx1367xdxbavv41qsmgkxhvbs"))))
+ (base32 "1r9gd4ffr8sh9y3ic8fxwgp4gjls2yd6bgsgvcf0vy571s2aqggr"))))
(build-system linux-module-build-system)
(arguments
(list #:tests? #f ;no test suite
@@ -1653,6 +1617,7 @@ display settings applets in graphical environments")
(mkdir-p lib)
(install-file "libevdi.so" lib)))))))
(inputs (list libdrm))
+ (native-inputs (list pkg-config))
(synopsis
"@acronym{EVDI, Extensible Virtual Display Interface} user-space library")
(description
@@ -1783,7 +1748,8 @@ graphics card on Optimus laptops.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "19vi7dk4jv5wm18cznz4lj2fb1c7m7j3ig62x4a6qy9djxf9z472"))))
+ (base32 "19vi7dk4jv5wm18cznz4lj2fb1c7m7j3ig62x4a6qy9djxf9z472"))
+ (patches (search-patches "ddcci-driver-linux-linux-6.8.patch"))))
(build-system linux-module-build-system)
(arguments
(list #:tests? #f ; no tests
@@ -4289,16 +4255,7 @@ to use Linux' inotify mechanism, which allows file accesses to be monitored.")
(symlink "kmod"
(string-append #$output "/bin/" tool)))
'("insmod" "rmmod" "lsmod" "modprobe"
- "modinfo" "depmod"))))
- (add-after 'install 'remove-libtool-archives
- ;; Libtool archives lists the whole transitive dependencies,
- ;; which is unnecessary unless producing static archives and
- ;; leads to overlinking, e.g. causing the build of
- ;; libblockdev to fail due to attempting to link with zstd.
- (lambda _
- (for-each delete-file
- (find-files (string-append #$output "/lib")
- "\\.la$")))))))
+ "modinfo" "depmod")))))))
(native-inputs (list pkg-config zstd)) ;zstd needed for tests
(inputs (list xz zlib `(,zstd "lib")))
(supported-systems (delete "i586-gnu" %supported-systems))
@@ -4377,7 +4334,8 @@ to the in-kernel OOM killer.")
(sha256
(base32
"1f6lz57igi7iw2ls3fpzgw42bfznam4nf9368h7x8yf1mb737yxz"))
- (patches (search-patches "eudev-rules-directory.patch"))))
+ (patches (search-patches "eudev-rules-directory.patch"))
+ (modules '((guix build utils)))))
(build-system gnu-build-system)
(arguments
(list
@@ -4453,10 +4411,7 @@ to the in-kernel OOM killer.")
;; and similar; it also installs the '60-persistent-storage.rules' file,
;; which contains the rules to do that.
(list `(,util-linux "lib") ;for blkid
- kmod
- ;; These are for the static archives.
- zlib
- `(,zstd "lib")))
+ kmod))
(outputs '("out" "static"))
(home-page "https://wiki.gentoo.org/wiki/Project:Eudev")
(synopsis "Userspace device management")
@@ -4600,6 +4555,7 @@ one to send arbitrary keycodes when a given key is tapped or held.")
(sha256
(base32
"0z6w6bknhwh1n3qfkb5ij6x57q3wjf28lq3l8kh7rkhsplinjnjc"))
+ (patches (search-patches "lvm2-no-systemd.patch"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -5334,7 +5290,7 @@ thanks to the use of namespaces.")
(string-append (which "env") " "
#$output "/bin/singularity")))))))))
(inputs
- (list bash-minimal ;for 'wrap-program'
+ (list bash-minimal
coreutils
libarchive
python-wrapper
@@ -7153,7 +7109,7 @@ not as a replacement for it.")
(define-public hotspot
(package
(name "hotspot")
- (version "1.4.1")
+ (version "1.5.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7165,7 +7121,7 @@ not as a replacement for it.")
(file-name (git-file-name name version))
(sha256
(base32
- "0wz4qr3dwjji79x7kj44g7xp11qsscp3b95h6627k8p7xbpi2vhd"))))
+ "17m96h0iahfjhbsa9flmsmbczvliy34vqvayzyh8bhldd8yh768l"))))
(build-system qt-build-system)
(arguments
(list
@@ -7242,7 +7198,7 @@ not as a replacement for it.")
karchive
kconfig
kcoreaddons
- kddockwidgets-1 ;see https://github.com/KDAB/hotspot/issues/610
+ kddockwidgets
kgraphviewer
kio
kiconthemes
@@ -8886,7 +8842,15 @@ libraries, which are often integrated directly into libfabric.")
"psm-arch.patch" ; uname -p returns "unknown" on Debian 9
"psm-ldflags.patch" ; build shared lib with LDFLAGS
"psm-repro.patch" ; reproducibility
- "psm-disable-memory-stats.patch"))))
+ "psm-disable-memory-stats.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; That file declares its own 'strlcat' as static. To avoid a
+ ;; conflict with the function now in glibc 2.39, give it a
+ ;; different name.
+ #~(substitute* "ptl_ips/ips_proto_dump.c"
+ (("strlcat")
+ "psm_custom_strlcat")))))
(build-system gnu-build-system)
(outputs '("out" "debug"))
(inputs `(("libuuid" ,util-linux "lib")))
@@ -9140,7 +9104,15 @@ privileges.")
(file-name (git-file-name name version))
(sha256
(base32
- "04nar65ac11qqx41vkfs7iip8kfiah0zms7l4rmsxncpiz2iqfik"))))
+ "04nar65ac11qqx41vkfs7iip8kfiah0zms7l4rmsxncpiz2iqfik"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; That file declares its own 'strlcat' as static. To avoid a
+ ;; conflict with the function now in glibc 2.39, give it a
+ ;; different name.
+ #~(substitute* "ptl_ips/ips_proto_dump.c"
+ (("strlcat")
+ "psm2_custom_strlcat")))))
(build-system gnu-build-system)
(arguments
(list #:make-flags