summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f27b8281ab..c5d055366e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -419,6 +419,15 @@ providing the system administrator with some help in common tasks.")
"/etc/bash_completion.d"))
#:phases (modify-phases %standard-phases
(add-before
+ 'build 'set-umount-file-name
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Tell 'eject' the right file name of 'umount'.
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "sys-utils/eject.c"
+ (("\"/bin/umount\"")
+ (string-append "\"" out "/bin/umount\"")))
+ #t)))
+ (add-before
'check 'pre-check
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))