summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm23
1 files changed, 19 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 78182555c1..4d24fcbd26 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2811,6 +2811,21 @@ to the in-kernel OOM killer.")
(string-append (assoc-ref inputs "xsltproc")
"/bin/xsltproc")))
#t))
+ (add-after 'install 'move-static-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (static (assoc-ref outputs "static"))
+ (source (string-append out "/lib/libudev.a"))
+ (target (string-append static "/lib/libudev.a")))
+ (mkdir-p (dirname target))
+ (link source target)
+ (delete-file source)
+ ;; Remove reference to the static library from the .la file
+ ;; such that Libtool looks for it in the usual places.
+ (substitute* (string-append out "/lib/libudev.la")
+ (("old_library=.*")
+ "old_library=''\n"))
+ #t)))
(add-after 'install 'build-hwdb
(lambda* (#:key outputs #:allow-other-keys)
;; Build OUT/etc/udev/hwdb.bin. This allows 'lsusb' and
@@ -2839,6 +2854,7 @@ to the in-kernel OOM killer.")
;; which contains the rules to do that.
`(("util-linux" ,util-linux) ;for blkid
("kmod" ,kmod)))
+ (outputs '("out" "static"))
(home-page "https://wiki.gentoo.org/wiki/Project:Eudev")
(synopsis "Userspace device management")
(description "Udev is a daemon which dynamically creates and removes
@@ -2931,8 +2947,7 @@ mapper. Kernel components are part of Linux-libre.")
(name "lvm2-static")
;; Propagate udev because libdevmapper.a depends on libudev.
- (inputs (alist-delete "udev" (package-inputs lvm2)))
- (propagated-inputs `(("udev" ,eudev)))
+ (propagated-inputs `(("udev:static" ,eudev "static")))
(arguments
(substitute-keyword-arguments (package-arguments lvm2)
@@ -3882,7 +3897,7 @@ Linux Device Mapper multipathing driver:
(define-public libaio
(package
(name "libaio")
- (version "0.3.111")
+ (version "0.3.112")
(source (origin
(method url-fetch)
(uri (list
@@ -3890,7 +3905,7 @@ Linux Device Mapper multipathing driver:
name "-" version ".tar.gz")))
(sha256
(base32
- "0ajhzbqjwsmz51gwccfyw6w9k4j4gmxcl2ph30sfn2gxv0d8gkv2"))))
+ "14mlqdapjqq1dhpkdgy5z83mvsaz36fcxca7a4z6hinmr7r6415b"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags