summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5c96056576..c5fed1a7c2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -426,11 +426,18 @@ It has been modified to remove all non-free binary blobs.")
;; ("cracklib" ,cracklib)
))
(arguments
- '(;; Most users, such as `shadow', expect the headers to be under
+ `(;; Most users, such as `shadow', expect the headers to be under
;; `security'.
#:configure-flags (list (string-append "--includedir="
(assoc-ref %outputs "out")
- "/include/security"))
+ "/include/security")
+
+ ;; XXX: <rpc/rpc.h> is missing from glibc when
+ ;; cross-compiling, so we have to disable NIS
+ ;; support altogether.
+ ,@(if (%current-target-system)
+ '("--disable-nis")
+ '()))
;; XXX: Tests won't run in chroot, presumably because /etc/pam.d
;; isn't available.