summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9dc5f5cd40..53368251b5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -292,6 +292,11 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
(alist-replace
'install ,install-phase
(alist-delete 'configure %standard-phases)))
+
+ ;; Use '--strip-debug', not '--strip-all', because the latter leads to
+ ;; unloadable modules (due to the lack of a symbol table.)
+ #:strip-flags '("--strip-debug")
+
#:tests? #f))
(synopsis "100% free redistribution of a cleaned Linux kernel")
(description